Hello Guest it is July 19, 2019, 11:11:56 AM

Author Topic: tip radius compensation problem  (Read 2588 times)

0 Members and 1 Guest are viewing this topic.

tip radius compensation problem
« on: August 25, 2008, 05:48:11 AM »
Hello Guys,
I am using mach 3 version  R1.84.001 DEMO on a lathe .
I find I cannot use or I am not able to use the tip radius compensation .
When I set the g41 or g42 the tool make an odd movement at any change of direction.
this is an example of program, what am I doing wrong?

(iso 40)

G18
G21
G42
G61
G90
G94
T0101 (utensile a sfacciatore)
F30
g0 x66 z2
g0 G42 x24 z2   
g1 z0
x26.66
x44.45 z-61.1
z-62.8
g2 x47.45 z-64.3 r1.5
g1 x61
g3 x64 z-65.8 r1.5
g0 G40 x66 z2

M30


Thanks for any info

best regards

Gianluca

Offline Graham Waterworth

*
  • *
  •  1,863 1,863
  • Yorkshire Dales, England
    • View Profile
Re: tip radius compensation problem
« Reply #1 on: August 25, 2008, 08:24:08 AM »
Try the code like this, when using compensation you must always move in the same direction, if you reverse your movement the the tool jumps to the other side of the line.

Tool comp in version 1.84 is not perfect at the best of times.

G18
G21 G40
G61
G90
G94
T0101 (utensile a sfacciatore)
g0 x20. z2
G01 G42 Z0  F30.
x26.66
x44.45 z-61.1
z-62.8
g2 x47.45 z-64.3 r1.5
g1 x61
g3 x64 z-65.8 r1.5
g0 G40 x66 z2
M30

Graham.
Never give up, time will pass, the cloud will clear, the sun will shine once more.
Re: tip radius compensation problem
« Reply #2 on: August 27, 2008, 01:00:50 PM »
I tried Your suggestion end the problem was reduced but still present where a radius is present, any other suggestion?

best regards
Gianluca

PS do not know how to post a photo here to show the odd movements