Hello Guest it is November 16, 2019, 06:46:22 PM

Author Topic: Mach3 Doesn't See Parallel Port Inputs  (Read 2748 times)

0 Members and 1 Guest are viewing this topic.

Mach3 Doesn't See Parallel Port Inputs
« on: August 10, 2008, 12:15:45 AM »
I now have three parallel ports in my PC.  All output signals work just fine, but Mach3 does not seem to "see" input signals on *any* of the cards!  I have enabled E-Stop on several different pins, and verified that a good signal is getting to the proper pin on the connector on the PC, but Mach3 does not acknowledge that the signal is present, regardless of whether it's configured active high or low, or which port or pin it is configured for.  The diagnostic screen also shows no activity on any inputs.
Is there some configuration step I've missed?  How can three separate parallel ports behave so strangely?

Regards,
Ray L.
Regards,
Ray L.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Doesn't See Parallel Port Inputs
« Reply #1 on: August 10, 2008, 02:56:12 AM »
please attach your xml and I will have a look at it to see if there are any problems there.
 Are you meaning any of the Inputs or are you trying to use pins 2-9 as Inputs?
Hood

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Mach3 Doesn't See Parallel Port Inputs
« Reply #2 on: August 10, 2008, 10:30:59 AM »
The parrallel ports are clearly not LPT1- which is already configured.

If you have put in cards for these ports, they will be programmable - and clearly you have not programmed them - or they are output only cards.

Have you used LPT1 (the old printer port) or not. Did this work ???.

I think it is the parrallel port cards configuration you need to look at.
Not me driving the engine - I'm better looking.
Re: Mach3 Doesn't See Parallel Port Inputs
« Reply #3 on: August 10, 2008, 05:46:48 PM »
D'oh!  I'm a moron!  I work so much with computers, where the first of anything is "0", the next "1", etc.  I had the E-Stop configured for Port "0", which, of course, means it's disabled.  As soon as I configured it for Port "1", it worked first try.

Regards,
Ray L.
Regards,
Ray L.