Hello Guest it is June 27, 2019, 07:08:37 AM

Author Topic: Opto Isolation Inhibits Pulse Stream ?  (Read 3979 times)

0 Members and 1 Guest are viewing this topic.

Opto Isolation Inhibits Pulse Stream ?
« on: July 24, 2008, 12:11:40 PM »
:)
There is an output on my new C11 BoB that will not pass the STEP pulses but will work for the DIR.
I first had the X axis connected and configured to OUT 2 STEP and OUT 3 DIR.  3 would toggle on/off when jogging but no pulse stream at 2.
Then connected and configured OUT 2 DIR and OUT 3 STEP and it works fine.
Just wondering if this is a common problem with isolation ?
Thanks

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Opto Isolation Inhibits Pulse Stream ?
« Reply #1 on: July 24, 2008, 12:46:46 PM »
You do not say what speed you are expecting these to work at. The Opto isolation is just another switch in the path of the current, and has a finite time to operate. The Dir is a relative slow pulse, whereas the Step pulse varies as to the speed of the axis. It may be that the opto chip has a fault on that particular path.

What happens with the other pins, you can configure Mach 3 to use any of the output pins. Is this the only one faulty, or is it more widespread. ???
Not me driving the engine - I'm better looking.
Re: Opto Isolation Inhibits Pulse Stream ?
« Reply #2 on: July 24, 2008, 01:14:55 PM »
Hi Jim,
I would expect them to to work at whatever speed Mach puts out through the BoB to the driver for an axis motor. In this case, it is relatively slow as I mentioned above, while jogging (at 10%). 
Out 2 and 3 are marked on the board for X Step and X Dir respectively. They will work fine if reversed.
I assume a bad chip as well but was curious as to how one could work "partially".

The others are fine.
Thanks,
RC

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: Opto Isolation Inhibits Pulse Stream ?
« Reply #3 on: July 24, 2008, 02:17:25 PM »
Hi, RC

Mach has adjustments for "pulse width" default is 0, But many boards need a little more time to see the Pulse "change of state".

In Motor Tuning you can set this to 0 - 5 us and in Ports & pins "Sherline 1/2 Pulse" mode to 40 us that over-rides the Motor Tuning setting.

Your BOB board OPTO's may be on the edge and need a little more Time to see Mach's pulses.

Your pin (2) may just be the slowest one, But still be in tolerance for the type of OPTO used.

Try setting your step & dir Pulses at 5 or Sherline mode and Re-try your pin 2 for step pulse.

Thanks, Chip
Re: Opto Isolation Inhibits Pulse Stream ?
« Reply #4 on: July 24, 2008, 02:31:40 PM »
Great info Chip, thanks.
The Step pulse is at 4 .
I'd rather not change it because that setting is used along with the other settings for the Spindle axis in order to get the analog voltage correct for the VFD. Which was a bit of a pain to set up.
I used the same out 2 on my other C11 for the step signal with the step pulse set at 1 and it worked fine. And on a C10 too.
I've never seen this limitation with the 3 CNC4pc boards that I have.
However..it is a new rev. board.
I asked Mr. Duncan but may have to wait until after vacation for an answer.
I have more outs than I need, can use one of the others.
Just as a test, I'll go to Sherline mode and try it.
Thanks Chip,
RC

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: Opto Isolation Inhibits Pulse Stream ?
« Reply #5 on: July 24, 2008, 03:18:27 PM »
Hi, RC

Looking at the board, It looks like the OPTO's are plug in type, Easy to change it out, That's nice.

Chip

Re: Opto Isolation Inhibits Pulse Stream ?
« Reply #6 on: July 24, 2008, 03:58:14 PM »
Yes..that is handy.
Chip, I just checked.
Outputs 3,4,5,6,7,8,9 all work well with the pulse set at 1.
Output 2 will NOT work with Pulse at 5, but DOES work in Sherline.
I think I may have 1 "Iffy" chip Chip. :D
We'll have to see what Mr. Duncan says. May be something else being a new rev. board. ( 7... I think)
Thanks again Chip,
RC 8)
Re: Opto Isolation Inhibits Pulse Stream ?
« Reply #7 on: July 25, 2008, 05:51:50 PM »
One more little tid-bit. I'm pretty certain that at slow jog, I am no where near this.....

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: Opto Isolation Inhibits Pulse Stream ?
« Reply #8 on: July 25, 2008, 06:01:35 PM »
Would think your  Kernel speed will determine what your Max KHz is so no way you will be anywhere near that unless you have a SS or similar ;)

Hood
Re: Opto Isolation Inhibits Pulse Stream ?
« Reply #9 on: July 25, 2008, 06:21:11 PM »
Thanks Hood. :)
I am at 60K with the Kernel.
BTW...This topic is out of that same "Egg Basket". ::)
RC 8)