Hello Guest it is October 23, 2019, 03:03:36 PM

Author Topic: General frustrations in Mach 3 setup...  (Read 2595 times)

0 Members and 1 Guest are viewing this topic.

Offline CHUFF

*
  •  12 12
    • View Profile
General frustrations in Mach 3 setup...
« on: July 15, 2008, 02:42:14 PM »
Setting something as simple as the Z axis depth. I can zero it in the DRO's, and can jog it if a project is not running, but can't 'tell' it to start and stop at a specific position unless I want to dig through lines of gcode and manually change them. I've loaded a VERY simple shape into LazyCam, and of all the options there, the only one that actually does anything is exporting the gcode.. which sounds great, IF LazyCam happened to pick the right paths and Z starting points, but there's no way to set them.  So in the end, you just "get what you get" with out the ability to modify either the tool path, or anything for that matter.

As well.. NOBODY has answered why I ended up with FIVE shortcuts on my desktop for ONE program.  If these are all to be configured for different types of tooling, grand, but they each behave differently and I can't seem to configure them.

Originally, I just wanted a three axis machine that I could attach a router to and let it cut wood or plastics.  I own a plasma cutter, and entertained the idea of making an attachment that I could mount the torch to so the machine could use it as well and I would then be able to cut mild steel as well. Mach 3 seemed the perfect solution along with Xylotex 425 steppers, and their three axis controller. I've watched several of the videos and OFTEN the narrator refers to something then says "We'll get to that in another video" and I never hear about it again.. even in other videos. As well, I'm watching these videos with the computer running Mach RIGHT next to the computer with the videos.. so I can copy all that the video does.. and often my program is either differently configured (old videos I suspect), or my program wont do what the one in the video is doing.

I admit, I AM using a laptop. I saw the minimum requirements for running Mach on the site and got a comp that met those requirements. I didn't see ANY warning about laptops before I acquired the comp for this purpose. This laptop is dedicated to JUST this. It doesn't go online or anything else and I've done the optimization suggestions listed. Well... all but the big starting in a different mode as I'm not very "Windoze" savvy (I'm a Mac user).  To be honest, the only thing I've seen that is buggy on a laptop is the actual control of the steppers, which seems to be ok here. The three motors on my counter all move when I jog them and such. I've not yet hooked my motors to the cutting machine though, as I wanted to make sure everything worked.

As I stated... I can jog motors. It will even run my little shape I've loaded.. but I can't modify tool paths, or configure starting Z axis, and LazyCam started my Z at +60 inches!! I only have a 9 inch travel for Z axis!  I haven't even looked into limit switches and such because nothing is on a physical machine yet. Xylotex and Mach haven't really shaken hands on how all that would be wired up anyway. I'm anticipating a whole new headache on that one.

I've looked through the forums, and even posted a couple times. I HAVE received answers and some were useful. I just don't want to have to keep asking questions that should have been answered in initial set ups, and typically that is the programmer's responsibility to explain basic set ups. As I've mentioned, the videos are either old or don't work so... now what?

If I can get the thing to configure, and cut a simple shape with a tool path that I choose, I suspect I can dig slowly into other possibilities. From what I've seen in the videos, this program is capable of FAR more complexity than I would ever need... but running three simple axis'? That SHOULD be simple. Any ideas on where I have to start???

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: General frustrations in Mach 3 setup...
« Reply #1 on: July 15, 2008, 03:03:25 PM »
I don't think you can blame Mach 3 if Lazy Cam does not do the buisiness. I have not used Lazy Cam, but there must be some way to set parameters before you start.

All you have said is that you have not got everything set up yet and you are running the motors on a bench or something.

Your laptop is OK, I run mine with one - dedicated (although I have a WiFi connection to my system to pass stuff about on). If you are worried about Zylotex (which I have not heard of) I would suggest that you buy a non-powered break out board, and three Gecko 201 drives. These work from the LPT1 port (25 pin printer port). The Geckos (rated at 7 amps and 70 odd volts) will power a wide range of stepper motors without difficulty.

As far as you difficulty with programs is going, you seem to be missing the first essential point of CNC. The machine must know where it is and what parameters it is working under. Specifying where 0,0,0 is is a must, and the total travel of each of the axis is a close second.
If your z axis is starting on the moon, it is because nobody has told it it can't do that.

I think you should build your machine first, and worry about what programs to use later. If you are professional or semi-professional, there are some good programs on the market that will satisfy most needs, and Mach 3 can run any GCode programs.

There is nothing wrong with writing your own GCode programs, in fact, unless you are routing a sailing ship on a choppy sea, it is nearly as quick to write your own programs. If it is for cutting shapes with your plasma cutter, then Mach 3 has controls for plasma cutters programmed in.

A good drawing program (2D) to draw your shapes, then a simple CAM program to convert that to a GCode program would suffice (there are several  you can download).
« Last Edit: July 15, 2008, 03:12:25 PM by jimpinder »
Not me driving the engine - I'm better looking.

DaveDoesIT

*
Re: General frustrations in Mach 3 setup...
« Reply #2 on: July 18, 2008, 01:41:00 PM »
I have not used Lazy Cam, but there must be some way to set parameters before you start.

...

then a simple CAM program to convert that to a GCode program would suffice (there are several  you can download).

Hi Jim,

I am suffering the same frustrations with LazyCam and as far as I can find there is no way to define the order in which the gcode is created. It just goes and does it whichever way it thinks and that is not good if you want an optimized toolpath. LazyCAM just decided to rapid through the bottom of a groove to an adjoining groove. Not a big deal on screen but in the lathe, quite nasty.

As to download GCode generating programs, care to name a few links?

Thanks

Dave