Hello Guest it is July 08, 2020, 08:02:22 AM

Author Topic: homing swithes  (Read 4894 times)

0 Members and 1 Guest are viewing this topic.

homing swithes
« on: July 07, 2008, 04:56:53 AM »
I am hoping that someone could help me ,when i turn on my mach do the X home bar light and the Y home light suppose to be on? mine are and i can not use the switches X and Y
Z axis works and the probe works also ,i did unplug the controller and they are still lit up

Johan

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: homing swithes
« Reply #1 on: July 07, 2008, 05:13:03 AM »
Not too clear what you are meaning but maybe changing the active state of you home switches is what you are looking for. You will find it in Ports and Pins then Inputs.

Hood
Re: homing swithes
« Reply #2 on: July 07, 2008, 09:29:45 AM »
yes you are right ,but when i do that my axis will go the other way when i tell it to go home ,and my swithes still dont work for the two axis
thank you for your reply,should these two lights not be off ?
Re: homing swithes
« Reply #3 on: July 07, 2008, 09:31:59 AM »
to add a little more information to this.  I hae talked with him on the phone about this issue.  Here is the break down.

With no limit switches connected to the machine (But they are set to active in ports and pins)  When he opens mach3  he gets the LED lights on the screen for x and Y next to the DROS Z led is not lit.

When physically connecting the switches and prode to the drier box.  The Z limit switch and probe do work.  But X and Y do not.   These switches have been proven to work on another system so that removes then from the problem.   
We hae changed the LPT port in bios from SPP to EPP and this does not help.

The cnc control system is from Minitech, there was a problem with the cnc control unit a year or so ago, but it has been repaired.  Limit switches have not been run on this machine in the past.  We have verified that the switches are setup correctly in ports and pins.

Hope the background on the issue helps diagnose the problem a little better.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: homing swithes
« Reply #4 on: July 07, 2008, 10:11:50 AM »
OK for the axis moving the wrong way you just alter the setting for Home Neg in Homing and limits page.
 Can you attach your xml to a post and we can have a look. To do that you go to the Mach3 folder right click and copy the xml then paste it on the desktop, right click it aand rename, suggest Golddust.xml. Then when you reply use the reply button and then you will see anadditional options button, clcik that and browse to your renamed file.
 The xml you are looking for in the Mach3 folder will depend on whether you are using a standard profile or a custom one, if its the standard mill one then its Mach3Mill.xml you want.

Hood

Offline jimpinder

*
  •  1,232 1,232
  • Wakefield, West Yorks, UK
    • View Profile
Re: homing swithes
« Reply #5 on: July 07, 2008, 01:20:15 PM »
You must try and understand how the LPT1 port works. All the input lines are pulled high +5v by internal pull up resistors. If you have the limit switches activated (but no limit switches attached) then the inputs are at +5 volts - and as far as Mach 3 is concerned this is the active state - so the led's light up.

To cancel the leds, then you must go into Config/Ports and Pins/Input pins and tick the  limit switches as "active low". This means that Mach3 will only recognise the switches as "on" when there is a 0volt signal on the pin.

When he connects the limit switches - what does he do - in other words, when the switch is NOT activated, what signal is connected to the pin - a 0v or a 5 volt. If nothing is connected, then the pin will assume a 5 volt signal with it's own pull up.

When the switch is activated, what does it do - does it connect thepin to 5 volts or 0v. If 5 volts, then in Post and Pins/Input signals, that needs to be shown as "active HIGH" in other words the "active low box is unticked. If 0 volts then the "Active low" box needs ticking.

You should be able to connect your switches, and see on the diagnostic page, the switch switching when you activate it manually.
Not me driving the engine - I'm better looking.
Re: homing swithes
« Reply #6 on: July 08, 2008, 08:07:25 AM »
here is his XML file I tried posting it yesterday but for some odd reason it didnt go!

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: homing swithes
« Reply #7 on: July 08, 2008, 08:26:21 AM »
None of your home or limit switches are enabled and also if you enable them you will need to change the pin numbers as you have them asigned to Output pins on Port 1. You also have an output enabled but dont have a port and pin asigned to it.

Hood
Re: homing swithes
« Reply #8 on: July 08, 2008, 08:31:07 AM »
we have been playing with the ports and pins..... they were enabled and set to the correct port (1) and pin.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: homing swithes
« Reply #9 on: July 08, 2008, 08:34:46 AM »
the xml you attached has them set wrong, either it is the wrong xml you have attached or you have them set wrong.

Hood