Hello Guest it is June 26, 2019, 07:02:04 AM

Author Topic: Goto Zero Command  (Read 3212 times)

0 Members and 1 Guest are viewing this topic.

Goto Zero Command
« on: May 15, 2008, 09:57:36 AM »
Mach is working fine on my X3, except when I use 'goto zero' Z & Y axis home ok, but X always stops away from home and i have to push twice sometimes three times to get back to zero, just annoying!

Anyone got an idea whats causing the problem?

Thanks

Mike

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: Goto Zero Command
« Reply #1 on: May 15, 2008, 10:05:01 AM »
When you say Home are you meaning the zero offset position you have set or are you meaning the actual reference position? The GoTo Zero button is just supposed to take you to your offset zero position. However regardless of what you are meaning there still seems to be something wrong as it is taking 3 or 4 attempts to get to your zero position, can you attach your xml file and I will give it a look and see if I can find anything wrong. The xml will be called Mach3Mill.xml unless you have set up a custom profile, you will find it in your Mach3 folder.
Hood
Re: Goto Zero Command
« Reply #2 on: May 15, 2008, 12:16:15 PM »
Hi Hood
Here is xml, hope you can find a glitch
Thanks
Mike

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: Goto Zero Command
« Reply #3 on: May 15, 2008, 01:43:41 PM »
Your Kernel speed is set to 25KHz and looking at your motor tuning it should be higher, set the Kernel to 45KHz and that should  sort you out.
Hood
Re: Goto Zero Command
« Reply #4 on: May 19, 2008, 12:48:31 PM »
Hi Hood
Thanks for the info , have looked through config but can't find kernel speed, any clues?
Mike

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: Goto Zero Command
« Reply #5 on: May 19, 2008, 01:43:32 PM »
Config menu then Ports and Pins. You will see the Kernel speed options as soon as that page opens.
Hood
Re: Goto Zero Command
« Reply #6 on: May 20, 2008, 11:20:51 AM »
Hi Hood
That did the trick works fine, I owe you a pint.
On another topic are you involved in the UK Mach meeting, have not seen any more info!

Thanks again

Mike

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: Goto Zero Command
« Reply #7 on: May 20, 2008, 01:53:13 PM »
Glad it helped Mike.
 No I am not involved with the UK meet, was hoping to get there but it seems it may not be going ahead now. I have not heard from Graham himself but I was told that when the folks with the hall found out there would be metal cutting machinery they almost had a heart attack and started mumbling about health and safety. With a bit of luck Graham will post some info one way or the other soon.

Hood