Hello Guest it is November 12, 2019, 09:32:24 PM

Author Topic: error in drill wizard?  (Read 4968 times)

0 Members and 1 Guest are viewing this topic.

Re: error in drill wizard?
« Reply #10 on: May 08, 2008, 03:42:20 PM »
thanks,for the moment i can always use mach2 to generate the gcode for the drill wizard and use Mach3 to execute.
Re: error in drill wizard?
« Reply #11 on: May 09, 2008, 02:16:59 AM »
Hello,

when i change Z=formatnumber(Abs(getoemdro(1004))*-1,4) in Z=(abs(getoemdro(1004))*-1) then there is no error,i think there is
something wrong with the format command.

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: error in drill wizard?
« Reply #12 on: May 09, 2008, 02:55:34 AM »
You are probably right - I do not know what the (4) signifies. It is NOT four numbers after the decimal point, becasue that only goes to two numbers before rounding up or down.

Perhaps Brian can have a look and let us know.
Not me driving the engine - I'm better looking.
Re: error in drill wizard?
« Reply #13 on: May 09, 2008, 04:26:25 AM »
Hello again,

I have not mutch experience in programming but i think have a solution for the drill problem.After reading the vbscript doc about the format function i change all the the lines with the function formatnumber into e.g.  Z=format(Abs(getoemdro(1004))*-1,"###,##").
Now it works correct.Maybe is this the reason:Country is set to United States in the International
section of the Control Panel.(page 75).

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: error in drill wizard?
« Reply #14 on: May 10, 2008, 04:38:38 AM »
I think you have probably found the problem - the formatting seems to work correctly here, but obviously not for you.
Not me driving the engine - I'm better looking.