Hello Guest it is September 23, 2023, 11:16:18 PM

Author Topic: Installation hangs  (Read 4878 times)

0 Members and 1 Guest are viewing this topic.

Installation hangs
« on: March 17, 2008, 11:59:49 PM »
I am trying to install Mach3 on my "new" PC without success.

PC is a Dell GX270 with a 2.4GHz Celeron with 512MB of memory.  OS is a severly nLited WinXP SP2.

Mach3 2.63 installer hangs almost immediately with the CPU pegged at 99% duty cycle.

3.037 installer doesn't even launch.  Nothing in the task manager at all.

For comparison, PCNC3 Release 1.7b (Tormach's customized Mach3) installs without a hitch.

I would appreciate any clues at troubleshooting this.  I want to try Mach3 for controlling my new lathe!


« Last Edit: March 18, 2008, 03:18:37 AM by zephyr9900 »

Offline Chip

  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Installation hangs
« Reply #1 on: March 19, 2008, 12:47:57 PM »
Hi, Randy

I have downloaded/installed both of them recently and had no problem at all.

Every once in awhile I've had a bad download also.

CPU % on install always run high hear, As with other programs 99-100 % with no lockup or problem.

Maybe try downloading to another computer and put the Install on a Mem-Stick.

Not Much Help Hear, I now.

Thanks, Chip
Re: Installation hangs
« Reply #2 on: March 19, 2008, 02:25:15 PM »
Thanks for the reply, Chip.  The control computer isn't connected, so I am downloading the files on my desktop PC and transferring via thumb drive.

I've downloaded 5 copies each of 2.63 and 3.037 installers, and each copy has a different MD5 signature, and fc shows a 115-130 word difference between the files.  But I think that is some kind of embedded datecode from HTML downloading (vs. FTP, which I know preserves the original file attributes.)

The Tormach Mach3 version installed in 30 seconds or so and is fully functional (well, I haven't actually hooked it up to hardware, but the program fires up fine...)  The "native" Mach3 installations hang for at least 5 minutes (that's all the patience I had before killing the installer with Task Manager!)

I have asked John Prentice (who did the Tormach version of Mach3) if he used a different installer, but haven't received a reply yet.

Beyond that, I guess I need to find out how to launch Mach with a different (lathe) screenset and try to use what I have.

Best regards,


Offline Hood

  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: Installation hangs
« Reply #3 on: March 19, 2008, 05:03:13 PM »
Did you previously have the Tormach version on the computer you are having problems with? If yes try uninstalling Mach from add remove programmes then delete the Mach3 folder and try again (remember to reboot after it installs)
 Not sure what the Tormach version is like but if you dont have Mach3 turn icons or options in the start list then browse to your Mach3 folder and double click on Mach3.exe, you should then be able to choose to make a profile. Again though this option may be missing from the Tormach version.
Re: Installation hangs
« Reply #4 on: March 19, 2008, 05:18:08 PM »
Hood, thanks for the suggestion but no, this was a fresh drive format and install.  I really would rather have a stock Mach3 install than kludge the Tormach version, so I'll do a fresh format and try the installation again, maybe in safe mode.  I haven't tried that avenue yet.

Best regards,

Re: Installation hangs
« Reply #5 on: March 19, 2008, 09:46:45 PM »
Strange, strange, strange.  I just noticed the FTP site and downloaded a copy of 2.62b.  It installed without a hitch.  There is something definitely odd with the 2.63 installer and my PC.  It would hang consistently when copying Mach3.exe onto my hard drive at 2846720 bytes.  Reboot after reboot, normal or safe mode, ultra DMA on or off.  Go figure.

Oh, and I was incorrect about the timestamp on FTP'ed files.  I was thinking of files from a self-extracting zipfile...

Best regards,


EDIT: Likewise the FTP'ed copy of 3.036 installed fine.  3.037 installer still hangs instantly.  Guess I'll stay with 3.036!  :)
« Last Edit: March 19, 2008, 10:18:24 PM by zephyr9900 »
Re: Installation hangs
« Reply #6 on: April 28, 2008, 06:25:04 PM »
Agreed - the download files blow badly.
I have reformatted my WindowsXP machine after all manner of safe restarts and a wasted weekend on this!!
I have tried both the current locked version and Dev version - both lock with TGSetup at 99% CPU. Mach3V1.6 installs immediately.

Will try as follows - moderators - do us a favor and post when fixed...

Re: Installation hangs
« Reply #7 on: April 28, 2008, 08:06:16 PM »
Ben, try getting a copy by FTP.  Go to ftp://machsupport.com/Mach and get it from there.  That solved my problem.  Hope it works for you!