Hello Guest it is January 27, 2022, 07:02:00 AM

Author Topic: Mach3 and Galil ... Getting better  (Read 17066 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach3 and Galil ... Getting better
« Reply #20 on: April 28, 2009, 08:11:24 AM »
Sounds like a problem with the gearing in the slave axis section of code.. I will see if I can look at it at some point..
Thanks
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline smurph

*
  • *
  •  1,475 1,475
  • "That there... that's an RV."
    • View Profile
Re: Mach3 and Galil ... Getting better
« Reply #21 on: April 28, 2009, 11:25:20 AM »
In the Plugin Configuration, do you have the auxiliary encoder checked?  e.g.  MPG1 = A and the aux check box.

Also, try running the plugin without the MPG configured.  Set MPG1, MPG2, and MPG3 to -1.  And uncheck any aux check boxes.  This should disable any MPG code and then we can see if you are still getting the "Galil error 46 Gear axis both Master and follower" error.

And while you are in the Plugin config, enable the debug output check box.  This creates a GalilDebug.txt file in the PlugIns directory.  Then restart Mach and try to connect.  If you get the error 46, exit mach and send me the GalilDebug.txt file at smurph@smcomp.com

Steve


Steve
Re: Mach3 and Galil ... Getting better
« Reply #22 on: April 28, 2009, 11:29:29 AM »
<G> Steve... I was thinking that I would look at that for you :) You are the man!
Thank you again for all you have done on this.. you truly are the Galil master at this point  ;D

Thanks
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline kcrouch

*
  •  193 193
  • In way too deep!!!
    • View Profile
Re: Mach3 and Galil ... Getting better
« Reply #23 on: April 28, 2009, 11:41:14 AM »
The error that you are getting is normal when the MPG input axis is selected as an output axis in either the Tab-out screen or by a brain file. The error is just a notification that the input and output are currently configured to the same axis, and does not cause an operational problem. Try setting the controlled axis in the tabout screen to something other than the mpg input and everything should work OK. The error message will appear again if you are toggling through the controlled axes with the tab-out screen, when you get to the output axes that is specified for the MPG input. Disabling the MPG will make the message go away, but you will then have no MPG function. The MPG jumps over any mapped axes.
Kenny
Having way too much fun! Something must surely be wrong.
Re: Mach3 and Galil ... Getting better
« Reply #24 on: April 29, 2009, 08:27:23 AM »
Thank you Mr.Steve.
After disabling handwheel the error disappeared.
Now I am trying to understand Mach/Galil IO interface before posting more question
Sivaraj