Hello Guest it is May 08, 2021, 12:53:58 AM

Author Topic: mach 3 keeps setting itself to incremental in the distance mode  (Read 10850 times)

0 Members and 1 Guest are viewing this topic.

I'm running window XP and i'm using Bobcad version 22 set for absolute arcs and Mach 3 set for absolute for the distance mode setting. Everytime I run my G code created in Bobcad I wind up with circular cuts that are slightly off, as in almost true but not exactly. When the code is finished running in Mach 3 the abnormal condition button flashes the message "G90/G91" and then mach 3 resets the distance setting to incremental. I've looked through the g code and i didn't see anything listing a G90 or a G91 which from what i understand represents incremental.

I've also set both Bobcad and mach 3 to incremental and my arcs are still off slighly and the same abnormal condition button flashes with the same G code related message.

Does anyone know what's going on and is this problem causing my arcs to me less than perfect?

Offline jimpinder

*
  •  1,232 1,232
  • Wakefield, West Yorks, UK
    • View Profile
Re: mach 3 keeps setting itself to incremental in the distance mode
« Reply #1 on: March 22, 2008, 04:48:12 AM »
When you say an arc - is either of the axis reversing direction - if so have you got backlash configured. If there is backlash, and you have not got it on, the arc will not be machined correctly.

Is there any tool compensation inserted - G41 or G42.

I can't think of anything else - but some of the G Code experts might help.
Not me driving the engine - I'm better looking.
Re: mach 3 keeps setting itself to incremental in the distance mode
« Reply #2 on: March 22, 2008, 03:07:38 PM »
There doesn't appear to be any backlash taking place, I've got a pretty tight machine. I looked at the code and I didn't see "G41 or G42. I'm still new at this so this may or may not be pertinent to the discussion but I am compensating for the tool in the tool path itself in regards to cutter diameter and type etc.

Initially i thought that the problem was due to the part moving under the side pressure of the bit and this does happen at times when the two sided tape fails to hold the part but this doesn't appear to be the case because all of the arcs have a certain portion that is irregular regardless if I'm cutting a circular pocket or  a circular profile cut. Since the "abnormal condition" alert flashes regardless of the setting in both bobcad and mach3 I'm thinking this is most likely the problem.

Does anyone else have any suggestions?
thanks in advance,
Nathan 
Re: mach 3 keeps setting itself to incremental in the distance mode
« Reply #3 on: March 22, 2008, 11:40:15 PM »
it looks like a Bobcad V 22 issue, the software is full of bugs. You can't set the post processor out of the box and it takes a couple of hours of tech support just fix the corrupted file causing the problem.

What it's doing now is putting out bad code 2 out of 5 times which forces you to start over again on a project. Then if you can get it to work and actually generate what looks like accurate machine code you find out quickly that it is mixing incremental with absolute which apparently is creating irregular cuts and repeated "abnormal condition" error messages and causing Mach 3 to reset it self to match the code when it finds a G91 which is aways there now matter what you set it for.

Offline jimpinder

*
  •  1,232 1,232
  • Wakefield, West Yorks, UK
    • View Profile
Re: mach 3 keeps setting itself to incremental in the distance mode
« Reply #4 on: March 23, 2008, 05:38:39 AM »
We have just had this on another post under a different guise.

The problem, I think, is to do with tool width compensation.

If you think about it, on tool width compensation the tool has a "shield" all around it - equal to the tool width radius. It has to be all way round, because unless the tool knows exactly which part of the tool is in contact with the work, it does not know in which direction to apply the compensation.

If you start at the centre of a circle (0,0) say of 1 inch diameter with a 0.25 bit, then the bit will travel out to (0.875,0) to start. There will be no compensation on the Y movement - because there is no movement on that axis.

If you then describe the circle, both axis are moving, therefore both will be compensated.

When you get right round and are approaching position (1,0) again the cutter will actually stop at (0.875,0125) - short of (0,0) on both axis (actually slightly less than 0.875 on the X) but you get the idea.

Depending on how the code is written, either the cutter will pull out and go back to centre, then repeat - with the same effect, or the cutter will take another pass, and overcut the part it had missed, but somewhere you will be able to see it.

How do you get round it - it depends - if there is no material in front of the cutter, you can move the cutter the extra 1/8" or whatever. I have not tried turning off the cutter compensation - and moving to (1,0) so whilst this would correct the Y axis shortfall, I am not sure of the effect on the X axis.

The complete answer is to program the G2 or G3, without cutter compensation on.

That is the theory from observations I made when cutting some (largish) windows with rounded corners with a large routing tool - it would never get right round. I had to compensate by starting halfway down a straight side and over-running on completion.




Not me driving the engine - I'm better looking.

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: mach 3 keeps setting itself to incremental in the distance mode
« Reply #5 on: March 23, 2008, 08:36:39 AM »
Hi faroutacrylics - Occasionally I get similar behaviour in as much as all the cuts are just slightly off the required toolpath. I raised this as an issue in http://www.machsupport.com/forum/index.php/topic,5035.0.html (see post #4)

Coincindentally it just happened to me again this morning. When you first set Mach up you'll remember that you were told that the "Config\Select Native Units" was to be used once and only once at setup and that if you want to change units you should use the Units toggle on the Settings screen or G20/G21 in your code. Well what you probably don't know is that Mach can sometimes change the "Config/Native Settings" all on its lonesome. I don't know why it does this but it does. The result is that it then miscalculates the toolpaths by just a smidge.

This morning when I had the problem I immediately checked what Mach thought were my native units and sure enough it had switched them from metric to imperial. I switched it back and my toolpaths are now spot on again. You'd think that by switching this from one to the other (on its own) then Mach would be out by a huge margin (25.4:1) one way or the other but that isn't the case - it's out by just a few 10ths of a mm in my case.

Mach can also switch your Distance Mode and IJ Mode for you when your not looking - though this tends to happen most (but not exclusively) when you upgrade.

Maybe not your issue - but worth a quick look.