Hello Guest it is October 22, 2021, 03:47:45 PM

Author Topic: Exact Stop G64  (Read 15868 times)

0 Members and 1 Guest are viewing this topic.

Re: Exact Stop G64
« Reply #10 on: May 10, 2006, 02:22:15 PM »
do you have backlash on?
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Exact Stop G64
« Reply #11 on: May 10, 2006, 04:38:11 PM »
Hi

We ran the machine with both backlash on and off to see if there was any difference but unfortunately no change, so we have left it turned off.

We have the acceleration set at 500mm per/sec and this is about where we can safely run the machine without the shudders getting too violent, so if we take the acceleration up much more than that we end up with extreme jolts inbetween each line of code.

We ran a test just doing g1 moves as suggested,  and the lines ran smoothly with no slowdown inbetween each line on both the x and y axis thought we would try g2 moves
e.g.  G2x50y100
       G2x100y200
       G2x200y300
       G2x300y50
and as soon as both axis moved simultaneously the shudders and acceleration and deceleration reappeared and the feedrate fluctuated from 0 up to max feedrate between each 'g2' move.
Thanks
Shelley

Offline Graham Waterworth

*
  • *
  •  2,394 2,394
  • Yorkshire Dales, England
    • View Profile
Re: Exact Stop G64
« Reply #12 on: May 10, 2006, 04:56:13 PM »
Hi,

it sounds a bit like lack of power to the motors, how big is your power supply?

Graham.
Without engineers the world stops

Offline ART

*
  • *
  •  1,702 1,702
  • Tough as soggy paper.
    • View Profile
Re: Exact Stop G64
« Reply #13 on: May 10, 2006, 05:11:22 PM »
Hi:

 This can be the Gcode, if its full of very short vectors ( very short) it can stall the CV modes and make things jerky. It doesnt sound like CV is acting up since the straight line test runs. Make sure CV feedrate is not turned on on the settings tab, also make sure Angular descrimination on the confif logic is left turned off. Either of those may do things such as this..

Art
Re: Exact Stop G64
« Reply #14 on: May 14, 2006, 03:35:12 PM »
Hi
Went through the setting and made sure that the cv feedrate and angular discrimination wasn't turned on, and it was already turned off so that wiped out that possibilty.

We went through and changed the machine over to run in imperial instead of metric and it definitely made the maching alot smoother, but it isn't feasible for us to run in imperial so the only way we can get around the problem is by having the motor tuning in imperial and the visual diplay and programs in metric it seems to have made things run a little smoother but by no means great the feedrate is still jumping all over the show and accelerating and decelerating while doing straight line moves.

Are you able to give us a piece of test code that we can run as want to make sure that our post processor out of Edgecam is working properly and spitting out the right kind of code that we need.

Any help would be great
Thanks
Shelley

Offline ART

*
  • *
  •  1,702 1,702
  • Tough as soggy paper.
    • View Profile
Re: Exact Stop G64
« Reply #15 on: May 14, 2006, 03:58:21 PM »
Hi:

 You can test it with just importing a bmp or jpog, that generates alot of codes..

  I tried your xml, but the file must be bad because the motors arent even turned on in it.
Send me your Mach3Mill.xml file. I tried running your code snipet below and it runs here without slowing, just a
bit of variabnce from 119 to abnout 120IPM.

  I need your xml file to see why yours woudl stop. Waht feedrate are you trying to run that snippet at?

Art