Hello Guest it is December 09, 2021, 07:48:16 AM

Author Topic: Terminate a brain with "run macro M650.m1s" ???????  (Read 34804 times)

0 Members and 1 Guest are viewing this topic.

Re: Terminate a brain with "run macro M650.m1s" ???????
« Reply #50 on: March 26, 2013, 12:13:44 PM »
the file i'm using is in that folder and i don't
have a file named macropump.m1s in there.
and i did try this before, it just changed the leds once
bunch of m##.m1s
thanks

p.s. if i don't have the DROs in the set file, will it work ?
« Last Edit: March 26, 2013, 12:22:51 PM by Kenneth »
Kenneth
Re: Terminate a brain with "run macro M650.m1s" ???????
« Reply #51 on: March 26, 2013, 12:22:42 PM »
Should be there, you must have lost it.  :D

Put you another one there, open the editor, paste in the stuff, then name Macropump.m1s.
No prob.
Russ
Re: Terminate a brain with "run macro M650.m1s" ???????
« Reply #52 on: March 26, 2013, 12:27:57 PM »
Better yet, just plop this in your profile macros folder

Just remove the KENNETH_
Re: Terminate a brain with "run macro M650.m1s" ???????
« Reply #53 on: March 26, 2013, 12:31:06 PM »

 

p.s. if i don't have the DROs in the set file, will it work ?


yep .. you dont need to see 'em, the macro is comparing them so it can show you the led's ... you dont need to see 'em at all.
Re: Terminate a brain with "run macro M650.m1s" ???????
« Reply #54 on: March 26, 2013, 12:40:27 PM »
i copied the file to c:\mach3\macro\userprofile
looked at my set file to see if the LEDS and DROs
were set the same(they are). i'm missing somethinbg else
as this doesn't do anything but change the LED once and
doesn't change the userdro to the same as oemdro.

will delete the dros after i get this straight
Kenneth
Re: Terminate a brain with "run macro M650.m1s" ???????
« Reply #55 on: March 26, 2013, 12:44:16 PM »
Do you have "Run Macropump" checked in Gen. Config ?
Re: Terminate a brain with "run macro M650.m1s" ???????
« Reply #56 on: March 26, 2013, 12:46:01 PM »
then shut down Mach and restart ... just for shts n' giggles.
Re: Terminate a brain with "run macro M650.m1s" ???????
« Reply #57 on: March 26, 2013, 12:53:47 PM »
did that(twice...while giggling)
when i open mach3, Y leds is lit. if i move it
with arror keys. it goes off(0) but if i move Z,
y dro changes. i check the set file and they are different.
yes Pump is clicked in general

oemdro = x 800
y = 801
z = 802

userdr = 2001 - 2002  -  2003
(changed em to stop using 2000)

p.s. i renamed the file from KENNETH_Macropump.m1s
to Macropump.m1s.
« Last Edit: March 26, 2013, 01:00:36 PM by Kenneth »
Kenneth
Re: Terminate a brain with "run macro M650.m1s" ???????
« Reply #58 on: March 26, 2013, 01:05:50 PM »
did that(twice...while giggling)
 

userdr = 2001 - 2002  -  2003
(changed em to stop using 2000)

 
;D
You did change every instance of the new dro's in the macro ?
You have tried so many things, you might have internal conflicts. Get rid of anything you're not using (been there)
Also, mine blinked a little strange at first (i think), loaded and ran a small gcode file and it's been perfect ever since. (don't know why that would matter though).
Re: Terminate a brain with "run macro M650.m1s" ???????
« Reply #59 on: March 26, 2013, 01:16:59 PM »
shut down mach3 and machscreen. opened macropump
and checked everything. i did have the dros off by one number.
(don't know why that matters) opened mach3 and poof....
working. they blink if i jog a few seconds but think it's just because
of the loop. THANKS !!!!!!!!!!!!!!!!!!!!!

Kenneth