Hello Guest it is June 19, 2019, 11:45:51 AM

Author Topic: Mach 3 + Featurecam + Drilling / Gouging / Broken Cutter problem  (Read 16373 times)

0 Members and 1 Guest are viewing this topic.

Hello,

I'm using Featurecam 2006 along with Mach 3 to machine parts.

Post Processor:

(FeatureMILL POST for MACH3 MILL rev1.0 - 03/05/2006)
(MACH3-MILL - rev1.0.CNC)
(NovaLab / CK)


G-Code:

N28625 X0.125 Y0.4 F6.0
N28630 Z0.1
N28635 G81 X0.125 Y0.4 Z-1.1 R0.1 F6.0
N28640 G80
N28645 Z1.2
N28650 X3.575
N28655 Z0.1
N28660 G81 X3.575 Y0.4 Z-1.1 R0.1 F6.0
N28665 G80
N28670 Z1.2
N28675 G91 Z0 M09
N28680 G40 G49 G17 G80 G61 G70 G90 (Inch mode & Exact Stop)
N28685 M91001
N28690 M30

In this case the program is drilling a 1/8" hole with a center cutting end mill.  However it seems like the "G80" codes screw up Mach3 and it will skip a line or two of code.  That can cause it to not move to the correct X/Y coordinate or not retract the cutter before moving on the X/Y plane causing the tool to gouge the part and break.  I've lost three 1/8" extra long end-mills to this problem to a tune of $33 in the last few days.

I'm not a CNC expert, I'm quite the CNC rookie.  I do the part design at my friends shop and then cut it at home on my Taig mill.  Does anyone know why this is happening?  Everything else seems to work great and the accuracy is spot on.  These are the very last lines of my 5700 lines of code for a particular part I'm making.  It's drilling two holes on a .4 Y center line on a 3.7" long part.  It will usually drill the first hole, retract partially and then gouge the part without doing the full retract to Z1.2.  I had to move the drill operations to last as it was screwing up one of my slotting operations due to it skipping lines.  Thus far I've only had it retract the cutter correctly once and then on my next part it skipped the Z1.2 line and ruined the part.  I own a Mach 3 license.

Servos: IM Service with Reducers, Nema 23
Control Board: CNC4PC Breakout Board
Drivers: Gecko G320


Please help.

Thank you!

Offline Graham Waterworth

*
  • *
  •  1,858 1,858
  • Yorkshire Dales, England
    • View Profile
Re: Mach 3 + Featurecam + Drilling / Gouging / Broken Cutter problem
« Reply #1 on: April 30, 2006, 05:00:40 AM »
Hi,

If I was doing this my code would look like this

G00 X.125 Y0.4           (MOVE TO FIRST HOLE)
Z1.2                            (MOVE TO SAFE RAPID)
G81 G98 Z-1.1 R0.1 F6. (START DRILL CYCLE)
X3.575                        (MOVE TO SECOND HOLE)
G80                             (CANCEL CYCLE)
G91 G28 Z0                  (GO TO HOME IN Z)
G28 X0 Y0                    (GO TO HOME IN X AND Y)
M30                             (END)

Not sure why it skips lines but the code is very odd. 

Graham.

G-Code:

N28625 X0.125 Y0.4 F6.0                        (FIRST HOLE POS)
N28630 Z0.1                                          (SHOULD BE MORE THAN .1  TO BE SAFE)
N28635 G81 X0.125 Y0.4 Z-1.1 R0.1 F6.0  (START DRILL CYCLE)
N28640 G80                                           (NOT NEEDED)
N28645 Z1.2                                          (NOT NEEDED)
N28650 X3.575                                       (NEXT HOLE POS)
N28655 Z0.1                                           (NOT NEEDED)
N28660 G81 X3.575 Y0.4 Z-1.1 R0.1 F6.0   (NOT NEEDED)
N28665 G80                                            (END CYCLE)
N28670 Z1.2                                           (NOT NEEDED)
N28675 G91 Z0 M09                                (ONLY TURNS COOLANT OFF, NO MOVEMENT)
N28680 G40 G49 G17 G80 G61 G70 G90    (NORMALLY AT THE START OF A PROGRAM)
N28685 M91001                                      (? LOOKS LIKE RUBBISH)
N28690 M30                                           (END)
Never give up, time will pass, the cloud will clear, the sun will shine once more.
Re: Mach 3 + Featurecam + Drilling / Gouging / Broken Cutter problem
« Reply #2 on: May 01, 2006, 06:32:25 AM »
If you would like I can send you theMach3 post that I use with feature Cam..
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Mach 3 + Featurecam + Drilling / Gouging / Broken Cutter problem
« Reply #3 on: May 01, 2006, 08:12:41 PM »
Brian,

That would be great if you could send your post processor my way.  My email address is david_wambolt[at]comcast.net

I was able to get past this problem by selecting combine like holes into the same cycle.  If that was not checked and I generated my G-Code, Mach3 would occasionally not process certain commands after G80.

Thanks for the tips - going back I was able to get it working flawlessly.  No more broken endmills!

This is the part I'm making: http://www.dmwtech.com/gallery2/v/machining/x1900/

It's my first CNC part - a replacement heatsink for a computer video card. Gotta start somewhere, right?
Re: Mach 3 + Featurecam + Drilling / Gouging / Broken Cutter problem
« Reply #4 on: August 25, 2006, 05:10:50 PM »

"If you would like I can send you theMach3 post that I use with feature Cam.."

I would love to get a copy of your Mach3 post as well Brian.

Keith
Re: Mach 3 + Featurecam + Drilling / Gouging / Broken Cutter problem
« Reply #5 on: August 25, 2006, 06:39:30 PM »
I don't have it with me :( I am out of work for a week... But if I end up going in I will get it for you !
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Mach 3 + Featurecam + Drilling / Gouging / Broken Cutter problem
« Reply #6 on: August 25, 2006, 06:57:42 PM »

Thanks Brian!

Offline 4l4

*
  •  2 2
    • View Profile
Re: Mach 3 + Featurecam + Drilling / Gouging / Broken Cutter problem
« Reply #7 on: August 29, 2007, 09:47:50 AM »
Hi i have a same problem. Im using FeatureCAM 2007 v13 + Mach3.
Could you send me a copy of your Mach3 post as well Brian ??? Many Thanx
Re: Mach 3 + Featurecam + Drilling / Gouging / Broken Cutter problem
« Reply #8 on: September 04, 2007, 08:27:52 AM »
This is one for 2005 I think but it is a good start..
thanks
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline 4l4

*
  •  2 2
    • View Profile
Re: Mach 3 + Featurecam + Drilling / Gouging / Broken Cutter problem
« Reply #9 on: September 07, 2007, 01:41:20 AM »
many thanx Brian !