Hello Guest it is September 17, 2019, 08:24:36 PM

Author Topic: Mach3 Screens Text and numbers do not fit screen layout/entryboxes properly  (Read 4986 times)

0 Members and 1 Guest are viewing this topic.

I normally use a hi res screen set to  1280 x1024 and experience no problems with any software except with Mach3. I have tried altering the configuration settings inside Mach3 but achieved no improvement in the appearance.  I also tried changing the screen to 1280 x 960 to maintain the same aspect ratio as 1024x768 with no effect. I am still experiencing truncated data displays. Does anyone know how to improve the presentation?

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Have you tried using Auto Enlarge setting in the General Config page?
 If you still have problems you can alter screensets by using he Screen4.exe programme, it should be in your Mach3 folder, if not you can get it from the downloads page.
Hood
Results:
17" LCD Monitor.
Auto sizing  with screen resolution set to 1280x960  (a multiple of 1024 x768) helps quite a bit with, but display of data is still not properly centered in the boxes (too low with  bottom of figures truncated). With LCD monitor set to 1024x 768 (A  bit out of the normal useful range these days), the data is not truncated., but actually slightly overlaps the bottom of the boxes.
****************
Using a 14", 1995 vintage, CRT monitor at the limit of its resolution (1024 x768) the display is correctly presented at all times. This is presumably more like the environment for which Mach3 was  designed.
****************
Thanks for your help

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Can you post a screenshot of what you get as all is OK on all of my 17inch TFT's set to 1024x768, also on my desk computer they are fine, its an 18inch  and I have tried both on 1280 x1024 and 1024 x768
 The screens are mainly designed at a 1024x768 resolution but if you wish you can design your own screen at any custom resolution you wish. I have done my own screen as have lots of others here. I chose just to use 1024 x768 as I use touch screens.
Hood
Two attachments as requested (In doc files).

Thanks again for your help
I have found the cause of the problem- It is a Windows XP setting

Check the following

Right Click on blank area of Display
In Display Properties window  select "Settings " tab
Continued #5 reply finger trouble!
Select "Advanced " box

MAKE SURE you have normal size fonts (96 DPI) selected.
I had the large size (120DPI) selected hence they overflowed the space allowed in Mach3

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Hi, Pchumphry

The lower part that's "gray" is part of the "full" screen.set. See below.

Thanks, Chip