Hello Guest it is August 18, 2019, 01:48:07 AM

Author Topic: Axis only goes one way  (Read 2913 times)

0 Members and 1 Guest are viewing this topic.

Axis only goes one way
« on: March 01, 2008, 08:29:47 PM »
Just starting up a Taig Mill and Mach3 for the first time.  The mill (and controller) have been run with Mach2 in the past (at least a year or more ago).  Everything worked fine, cut some stuff.  When I use the cursor keys to jog, the X axis will only move one direction with either the left or right arrow key pressed.  If I enter a positive or negative value (g0 x1 OR g0 x-1) into the MDI line the axis still goes only one direction.  Granted, I've just hooked the PC and controller together for the first time in over a year, but they did work together with Mach2.  No changes electronically have been made.

Thanks,
Monte
PS: Is the animated Merlin character part of Mach3, or Windows XP?  I'd really like to make it disappear.

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Axis only goes one way
« Reply #1 on: March 01, 2008, 09:10:11 PM »
Hi, Monte

Check in Config, Ports/Pins, Motor Output's, Change the Dir & Step Low-Active state, thay all should be set to "X" or "Check", If your axises don't run in the correct Direction , Use "Reversed" in Config, Home & Limits page.

Hope this Helps, Chip

PS: Can't remember where to turn him off
« Last Edit: March 01, 2008, 09:12:40 PM by Chip »
Re: Axis only goes one way
« Reply #2 on: March 01, 2008, 09:12:57 PM »
Got the axes going the right way, had to change the Pin#'s for the Motor Outputs to match the Xylotex Pin#'s.

Still not too sure about Merlin.

Monte

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Axis only goes one way
« Reply #3 on: March 01, 2008, 09:22:13 PM »
Hi, Monte

That will do it every time.

Cchip