Hello Guest it is July 08, 2020, 11:36:38 AM

Author Topic: Mach3 shutting down  (Read 4684 times)

0 Members and 1 Guest are viewing this topic.

Mach3 shutting down
« on: November 05, 2007, 07:47:04 AM »
Help!  Mach3 is shutting down for no apparent reason. :'(  When I try to restart Mach3, it says there is a Mach3 DLL initialization error and I end up having to reboot.  This computer is relatively new and is running XP.  It seems to happen during periods when nothing is being done.  Any ideas? 

Thanks,
Keith Clark

Offline Whacko

*
  •  239 239
  • Happy Days
    • View Profile
Re: Mach3 shutting down
« Reply #1 on: November 05, 2007, 01:35:05 PM »
Try running the Specialdriver.bat file in the Mach3 directory. You might have a hardware conflict. It could also be a Macropump issue? Are you running a macropump?

Whacko
Nothing's impossible
Re: Mach3 shutting down
« Reply #2 on: November 05, 2007, 08:01:59 PM »
I tried the special and the original driver and the same problems happens.  I do have a charge pump in operation.

Offline Whacko

*
  •  239 239
  • Happy Days
    • View Profile
Re: Mach3 shutting down
« Reply #3 on: November 06, 2007, 02:37:14 AM »
This could become technical. Also, when last did you do a defrag on your hardrive? Then, you could also have a virus/worm/trojan causing instability. Especially since it is a dll issue. Do you connect to the internet with the computer in question?
Mach3 has done the same with me, but that's because I was editing a macro which was running in the background.
A suggestion, disconnect the parallel port and simulate the program, check if the crashes still happen. You could also check the CPU load. What is the CPU load while you are running Mach3?

Whacko
Nothing's impossible
Re: Mach3 shutting down
« Reply #4 on: November 06, 2007, 06:21:11 AM »
It looks like a noise issue. ???  I hear some buzzing in the servos with spurious characters appearing in the editor program during editing and sometimes Mach shuts down.  It seems like things have gotten worse since I installed the limit switches and I realize that I forgot to ground the shields.  Also, the Mach pulsing engine completely disappeared and I had to reinstall the software.

This computer is not in the internet and never has been so I do not have antivirus or spyware.

I will try your suggestions.  I appreciate your help!

Thanks!

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Mach3 shutting down
« Reply #5 on: November 06, 2007, 09:44:45 AM »
I know you said it isn't hooked to the internet and never has been but, does it have a wireless network connection?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Whacko

*
  •  239 239
  • Happy Days
    • View Profile
Re: Mach3 shutting down
« Reply #6 on: November 06, 2007, 10:08:36 AM »
Could be noise. It could be a faulty keyboard. Sticky keys. Check what happens if you turn of the typematic rate in the bios. Even repositioning the keyboard could help. I think you should first try another keyboard to eliminate a possible faulty keyboard.

Whacko
Nothing's impossible
Re: Mach3 shutting down
« Reply #7 on: November 06, 2007, 11:03:28 AM »
Interestingly, I disconnected the limit switches to no avail.  Then I defragmented the hard drive which did need to be done according to the utility program.  So far the problem has stopped.  I reconnected the limit switches and no problem.  I still hear some noises on the  large servo but so far so good.  I will have to spend some more time to see if it was a temporary lull or a permanent improvement.

I don't have a wireless connection.  The network settings are as they would be by default for a new computer.

Thanks

Offline Whacko

*
  •  239 239
  • Happy Days
    • View Profile
Re: Mach3 shutting down
« Reply #8 on: November 06, 2007, 01:30:16 PM »
If the PC is not old, it's odd that the hardrive needed a defrag. What can happen, if the ram installed on the PC is small and is shared as well by a onboard video driver, Windows will use the hardrive more often for cached memory, the pagefile with other words. If you have a led indicating hardrive activety, check if it is busy. The cure then is obviously to increase ram size. I find 1 gig ram saves a lot on the hardrive.

Let's hope it solved your problem.

Whacko
Nothing's impossible
Re: Mach3 shutting down
« Reply #9 on: November 07, 2007, 05:49:43 AM »
I must tell you what I have discovered so others may benefit.  I was using an indestructible keyboard.  This is one of those that is like a rubber coated mat with keys imbedded in it. It sounded great for a dirty environment like a machine or woodworking shop.  It was apparently generating key strokes when I touched it causing the spurious entries in the text editor and causing the exit from Mach.  With another keyboard installed I have worked for hours with no problem.  The degragmenting  of the drive was not the fix because the problem returned after the degrag and before the keyboard swap. Sure feels good to get the gremlins out!!