Hello Guest it is July 14, 2024, 04:50:50 AM

Author Topic: Mach 4 Go To Work Zero button not working.  (Read 1225 times)

0 Members and 1 Guest are viewing this topic.

Mach 4 Go To Work Zero button not working.
« on: January 05, 2023, 04:37:55 PM »
The Problem is I have no A-Axis (Actually the A-Axis is slaved to Y) so I get an error message. From watching U-Tube videos, I understand that I need to remove the "Go to A0 command in ScreenScript.lua. The problem is ScreenScript is read only. I went into the file properties and gave myself access, but when I opened Mach to edit the file, Mach reinstated read only. How do I get around this? I tried modifying the file with an external text editor and that didn't work either.

Tony

Offline Bill_O

*
  •  581 581
Re: Mach 4 Go To Work Zero button not working.
« Reply #1 on: January 05, 2023, 05:55:03 PM »
You need to do the change withing Mach4

Go to Operator then Edit Screen
Click on the top thing under Screen Tree Manager
Under Properties click the center icon (Events)
Next to Screen Load Script (right side) click on the box then the button with 3 dots
This will pull up the ZeroBrane editor
Comment out what you need to and save it.
Go to Screen then click Save Screen
Go to Operator and deselect Edit Screen
Re: Mach 4 Go To Work Zero button not working.
« Reply #2 on: January 07, 2023, 10:49:48 AM »
Bill... Thanks for the reply.

All went according to the instructions until I got to "Go to Screen then click Save Screen". I was not able to find those buttons on the editor. If I close the editor it asks if I want to save the file, but if I click YES it says I don't have permission.

Tony

Offline thosj

*
  •  532 532
Re: Mach 4 Go To Work Zero button not working.
« Reply #3 on: January 07, 2023, 12:08:03 PM »
Try right clicking the icon you use to start Mach4 and choose Run as administrator, then try your edit to the screen.
--
Tom

Offline smurph

*
  • *
  •  1,548 1,548
  • "That there... that's an RV."
Re: Mach 4 Go To Work Zero button not working.
« Reply #4 on: January 21, 2023, 03:25:59 AM »
Bill... Thanks for the reply.

All went according to the instructions until I got to "Go to Screen then click Save Screen". I was not able to find those buttons on the editor. If I close the editor it asks if I want to save the file, but if I click YES it says I don't have permission.

Tony

The are on the menubar, not buttons.  When you are in screen edit more, "Screen->Save Screen"

Steve
Re: Mach 4 Go To Work Zero button not working.
« Reply #5 on: January 24, 2023, 11:30:50 AM »
Thanks Steve. I upgraded to build 5000 and now the Work zero button is working. Problem I'm trying to resolve now is all the axis are moving in the wrong direction.

Tony