Hello Guest it is December 05, 2021, 06:41:50 AM

Author Topic: Warp9 ESS spindle control issues HELP!  (Read 95 times)

0 Members and 1 Guest are viewing this topic.

Warp9 ESS spindle control issues HELP!
« on: October 15, 2021, 02:30:12 PM »
Right..

So i recently added a warp9  ESS smoothstepper to my system.. not without its issues.. but getting there now however the issue i have is as follows:

Spindle control...
I changed no settings when adding my ESS to my system. But now have poor spindle control and index feedback.

No matter what i try i cannot get the spindle to run a constant speed it fluctuates up and down when turned on in either direction (m3/m4) and the faster the spindle runs the more it fluctuates that much that if you try to run spindle calibration it gets to around 500rpm and then stalls calibration software due to that much fluctuation in speed and it not being able to stablise it.

The index disk i have has 1 slot which is approx 10mm wide

with the debounce interval and index debounce in general config what should i set these to? or are these not used with the ESS config noise filtering option being used instead?

the sensor i have is for index pulse is:

https://uk.rs-online.com/web/p/slotted-optical-switches/3031192

could the issue maybe be - main config ess - motor options - spindle set to 32khz? is that correct?

i have attached a photo of my vfd info sticker, the vfd is controlled by bob 0-10v output

the BOB i have is:

https://www.cnc4you.co.uk/Breakout-board-CP0-10V-CNC-4-Axis-with-Charge-Pump

what should my P I D settings be set to?

Hopefully someone can help.. as i'am completely stuck and its the only thing holding me back from running machine now.
Re: Warp9 ESS spindle control issues HELP!
« Reply #1 on: November 21, 2021, 12:40:45 PM »
Hi, I'm having the same issue as you, did you get in sorted?

Regards

Dale