Hello Guest it is November 30, 2021, 08:01:20 AM

Author Topic: All was fine, then Huanyang spindle started fluctuating in RPM. Cant find cause  (Read 201 times)

0 Members and 1 Guest are viewing this topic.

There was an old post with someone saying they had the Exact symptom I have, but there was no solution.  I was working normally yesterday, but then when I ran the next job, I heard the spindle RPM fluctuating (pulsating) about +/- 400RPM swing according to the digital readout on the inverter.  ..about 1 cycle per second of audible change in RPM swing.

Setup:
Mach 3.  UCETH300 with CNC4PC C76 board.   2.2KW Huanyang spindle (110V) connected as per spec between the inverter and C76 board.

Arturo @ CNC4PC says he's never seen this issue before.  I discovered the 0-10V analog outputs on the C76 board dropped from what used to be a working 0-10v swing to 0-4.2V  AND  The Spindle started pulsating RPM.    Even though the voltage is not what it used to be when it was working, it does seem stable on my analog and digital meters. - so why the pulsating all of a sudden?

Tried a backup install of Mach3, same issue.  Arturo suggested trying Mach4 in demo to see if the voltage/pulsating persisted, but I spent 2 hours trying to figure out why M4 wouldn't come out of E-stop, so I haven't completed that test yet.

Anyone have a similar issue?   It seems to point to a hardware issue on the CNC4PC C76 BOB, but with the voltage "wrong but stable" I can't figure out why the spindle RPM isn't stable.   When run manually (J1 jumper to VR and PD001=0 and PC070=1) the spindle works perfectly and steady from the inverter panel controls.

Lastly, and most oddly, I'm also not witnessing the voltage to S<rpm> commands reversed.  S100 is commanding the 4.2V now, and S24000 is getting me 0V.  Linear in between.  This is causing the spindle to spin SLOW at S24000 commands and FAST at say, S100 commands.    All this just happened out of the blue and I can't figure out why.
« Last Edit: September 15, 2021, 11:39:22 PM by jhgroenjes »

Offline Tweakie.CNC

*
  • *
  •  8,863 8,863
  • Super Kitty
    • View Profile
    • Tweakie.CNC
As it happened 'out of the blue' so to speak it could well be a corrupt Mach3 profile. Mach3 keeps copies of earlier settings so try loading an earlier copy (from a time before the problem existed). Check Operator / Restore Settings then follow on-screen instructions.

Hope this helps.

Tweakie.
KEEP SAFE !
Check my logic on this one:   So, whenever I suspect "corrupt anything" I've been successful in the past by just renaming C:\Mach3 to C:\SpindlePulsates9-15-21\ and then copy over the entire Mach3 folder and subfolders from my occasional backups on OneDrive.    Whenever I have a known, good, working set of macros, screen sets, keyboard shortcuts, etc. (I do a lot of tweaking. :) ) I make a back up copy of the entire C:\Mach3 folder for future restoration to that state if needed.  Is that a proper technique or would I still be "missing something"?      If indeed there was corruption in my working c:\Mach3 folder, I've already tested that by using a backup from mid 2020 and that did NOT fix the issue. - same exact symptoms.   I also downloaded a brand new C76.xlm file from the web to try that, and it too had the same symptoms.       

I wasn't aware of the Operator Restore function, so I can give that a go and report back.
« Last Edit: September 16, 2021, 09:00:47 AM by jhgroenjes »
I have another question/test to run by the forum here:   As a test, can you just take a 1.5V AA battery and put the V1 lead from the Spindle Inverter on the + and the ACM lead on the negative?   Then, when I issue an M3 S<wahtever> from Mach3, would that work?   Trying to prove that the DC signal from the CNC4PC C76 board is what's indeed causing the Spindle to have unstable RPM's.    As mentioned above, the Spindle IS Stable and works fine when put back into "manual mode" where you start/stop it from the LCD panel on the inverter and control the RPM with the on-board pot.   My meters aren't reading a fluctuation in the C76 output, but I figured an AA battery might be a good test.  thoughts?

I am working this exact same issue with the same C76 board.  Mine didnt happen out of the blue, its been like this since I wired in the C76.   The big difference is that I am using a NSK VFD/Spindle.   Where are you getting the 24V from that goes out to the VFD?  I am going to assume that it is coming from the screw terminals never to the power in to the C76.  Putting a separate 24v power supply in the controller for only these 2 wires seems to help a lot.
After working with Arturo for a just about a week.  We have come to this solution.
I hope it helps with your issue. 

https://youtu.be/ycoXvq-6qwU
Wow, nice job on the capacitor fix to your 0-10V fluctuation problem.   Let me add to this discussion a bit more, because I could see from your video that you didn't have Another Layer of issue that I DID.   You simply had the fluctuation, I had that, AND, my 0-10V output REVERSED in polarity and would only reach -4.2V DC.  (this caused S100 to be higher RPM's and say, S20000 to be low!)  Your video showed around +5V and the polarity (as you correctly identified with the orientation of the capacitor) was not reversed.    Therefore, my hardware failure of my C76 was a bit "deeper" than yours and "may" be a future indication of what might happen next with your board.  (just a guess).  Keep any eye on it.  If you see other issues, I suspect your C76 is failing more in the manner mine did for this circuit.

Funny that you and I both were working with Arturo on a very similar issue at the same time.

I ended up purchasing another C76 board, which came in Just Today.  Took me 20min to move all the wires connectors and the UCETH300 over and powered it up.   Worked Perfectly.  My polarity was back correctly and the 0-10v swing was commanding exactly as it should.  No changes on the Mach3 side at all.

I spent 2 weeks installing Mach 4 as a test and doing all sorts of restores of Mach3 config files and none of that was the issue.  I simply had a HW failure in this circuitry on the C76 and Arturo (and I believe him) said he'd Never Seen that type of failure before on this board.  ..not sure of the RPM fluctuation alone as been seen before, but I of course had the reverse polarity and low voltage issue too.

Good news that we're both fixed and up and running now.  I'm glad these forums exist to help each other out.

cheers.