Hello Guest it is January 20, 2022, 05:51:17 PM

Author Topic: Mach3 device error triggered when homing  (Read 262 times)

0 Members and 1 Guest are viewing this topic.

Mach3 device error triggered when homing
« on: June 11, 2021, 03:00:38 PM »
X homes perfectly Z homes perfectly. Y axis gives device error triggered when it reaches proximity switch. A axis is slaved to Y.   I’ve tried setting the debounce very high   No joy!  This is a wixhc USB controller and everythiyng else works. I’ve been trying to solve this for over a year off and on. I’d love to be able to home this. Any suggestions welcome. Thanks! I
Re: Mach3 device error triggered when homing
« Reply #1 on: June 11, 2021, 09:59:49 PM »
Hi,
I'm not a fan, and never have been, of using one switch as a Limit switch AND a Home switch.

My machine has dedicated Home switches, and where fitted, separate Limit switches, each on separate inputs.

The reason I prefer this is that when Mach is 'Homing' or 'Referencing' it treats Limit switch events as Home events, and in all
other operating modes it treats them as genuine Limit events and EStops as its supposed to. I suspect the reason that so many Mach users combine
Limit and Home in one switch is that was the practice which dates back to the Parallel Port which had so few inputs that you effectively had to combine
switches in creative ways. Nowadays with external motion controllers having many spare inputs there is no need to combine them, but the practice persists.

Your issue sounds like Mach is interpreting the switch event not as a Home event but a Limit event, even though its not supposed to.

May I suggest that you (in Ports and Pins) disable the Limit switch on that axis in the Inputs page but retain the switch as a Home switch only.
If you do this as an experiment it should prove whether Mach is mistakenly reacting to the switch event as a Limit. It may also suggest to you a solution.

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach3 device error triggered when homing
« Reply #2 on: June 12, 2021, 07:33:13 AM »
I actually don't even have limit switches set up or enabled. Maybe its expecting them to be there and they are not. I've always wanted homing more than limits, lol. Thanks for the reply!
   
Re: Mach3 device error triggered when homing
« Reply #3 on: June 12, 2021, 09:22:55 AM »
So now I get home switch triggered but it doesn’t reference home like the other two axis.
Re: Mach3 device error triggered when homing
« Reply #4 on: June 29, 2021, 11:17:53 PM »
Hi all. I hate to interrupt this thread but I am having the same issue only my problem is intermittent and on the Z axis. Yes I am using 1 switch for both. When it happens there are times that the gantry will start to move the X axis and then estop because of the Z switch. Can noise also cause this? I can start a new thread if needed.
Todd