Hello Guest it is November 27, 2021, 07:40:57 AM

Author Topic: bug in dev. ver 700 and 703  (Read 451 times)

0 Members and 1 Guest are viewing this topic.

Offline Stuart

*
  •  287 287
    • View Profile
bug in dev. ver 700 and 703
« on: April 01, 2021, 05:16:47 AM »
okay I know thase are dev vers.   so with that out of the way

I run the industrial version
I was running rel. 612 with the new mach4 ind screen.set and things run okay. ( foolish me got thinking very dangerous )

so the cnc mill was idle so I tried dev ver 700 looked fine ran ok but as luck would have it I needed to use the offset page but I altered the gauge pin DRO for the tool setup but it did not stick nor did it update this then I found was the same for all the DRO on that page this also is the same in the dev ver 703

as a test I copied the screen set out of the m4 dir for testing see below

update/regressed to 612 and every thing worked as expected I even tried the copied screen to make sure and that worked as well


so I think something has changed in the dev vers

thanks
Stuart

Offline Stuart

*
  •  287 287
    • View Profile
Re: bug in dev. ver 700 and 703
« Reply #1 on: April 01, 2021, 06:13:08 AM »
FYI
I made a backup of my running system
deleted the dir
then I tried a virgin install of 703 and the offset page DRO were not able to be updated

Offline smurph

*
  • *
  •  1,475 1,475
  • "That there... that's an RV."
    • View Profile
Re: bug in dev. ver 700 and 703
« Reply #2 on: April 02, 2021, 01:52:46 AM »
What are these 612, 700, and 703 numbers?  Do you mean 4612, 4700, and 4703?

Offline Stuart

*
  •  287 287
    • View Profile
Re: bug in dev. ver 700 and 703
« Reply #3 on: April 02, 2021, 02:16:33 AM »
yes

sorry I am dyslexic so I have trouble getting stuff down

Offline Stuart

*
  •  287 287
    • View Profile
Re: bug in dev. ver 4700 an 4703 and now still in 4707
« Reply #4 on: April 12, 2021, 09:33:04 AM »
I have just tested the latest Dev Industrial release ( that what I am licensed for ).

dev release 4707 dated 10/4/2021 still has the issues with the DRO on the offset page eg they are not able to be changed and revert back to the original setting its all three that do not works correctly

and yes I have pressed enter after changing the numbers but no go


as a test I installed an older screen set and that also failed

but 4612 with the supplied screen.set is ok

Stuart

Offline smurph

*
  • *
  •  1,475 1,475
  • "That there... that's an RV."
    • View Profile
Re: bug in dev. ver 700 and 703
« Reply #5 on: April 12, 2021, 07:42:32 PM »
Stuart,

Please call or create a support ticket for this.  You have phone support with your Industrial license. 

Steve

Offline smurph

*
  • *
  •  1,475 1,475
  • "That there... that's an RV."
    • View Profile
Re: bug in dev. ver 700 and 703
« Reply #6 on: April 12, 2021, 07:43:21 PM »
For clarification, it has to be a screen set issue and the support guys should be able to help you out quickly. 

Steve

Offline Stuart

*
  •  287 287
    • View Profile
Re: bug in dev. ver 700 and 703
« Reply #7 on: April 13, 2021, 02:23:54 AM »
thanks Steve

I will do some poking and try a

backup of my working mach4 dir and then delete that dir.

then I will install a new virgin install of the latest build and test from there as I have a backup its a simple test

 i will report back here in the first instance and take your advice to get touch

Offline Stuart

*
  •  287 287
    • View Profile
Re: bug in dev. ver 700 and 703
« Reply #8 on: April 13, 2021, 05:57:25 AM »
Steve I have poked it with a pointy stick

conclusions

4637 works, copied the screen set ( latest one)
tried 4707 with the copied screen no go

as a sanity check on my part compared the screen set that worked and the one that did not zero differences

so I have raised a ticket ( phone is no use , I cannot lip read a phone , I can hear a bit but to pass info is a no no )

thanks again