Hello Guest it is May 14, 2021, 08:40:52 AM

Author Topic: Map surface wizard does not function  (Read 226 times)

0 Members and 1 Guest are viewing this topic.

Map surface wizard does not function
« on: March 16, 2021, 01:41:26 PM »
Hi all,

I am trying to engrave some PCBs and having difficulties with Map Surface wizard, when map surface button clicked X and Y axis moves to the machine coordinate 0 point but Zth axis does not make any move, wizard stops there, therefore it can not probe the surface of the PCB. Please check the attached video.

Anyone having difficulties with Map Surface wizard? or anyone using it with success?

I contacted with support team they said it is working without any problem and advised me to make new profile from scratch, i did it, also used the default screen set but the problem is same, it still does not function and act the same way.

Last version of ESS and Mach4(4.2.0.4680) is installed but reverting back to 4.2.0.4612 because 4680 has some problems with the screen, there is some latency with the clicks on screen and machine movement in manual override.

But this Map Surface wizard problem is there in every Mach4 version for me, any suggestions?

Regards,

Hakan

Offline smurph

*
  • *
  •  1,402 1,402
  • "That there... that's an RV."
    • View Profile
Re: Map surface wizard does not function
« Reply #1 on: March 17, 2021, 12:35:39 AM »
Use 4682 and update your video driver possibly?  Nobody else has complained about screen 4680 issues. 

Steve
Re: Map surface wizard does not function
« Reply #2 on: March 17, 2021, 05:42:27 AM »
Hi Steve,

To be sure i am going to install Win10 32Bit to the controller(Win10 64bit is running now) and install everything from scratch including drivers, Mach4 and the profile, thanks.

Regards,

Hakan

Offline smurph

*
  • *
  •  1,402 1,402
  • "That there... that's an RV."
    • View Profile
Re: Map surface wizard does not function
« Reply #3 on: March 17, 2021, 01:36:18 PM »
I recommend sticking with Win10 64.  I so want to get away from 32bit stuff. 

Steve
Re: Map surface wizard does not function
« Reply #4 on: March 17, 2021, 10:20:20 PM »
steve
when i use c# as interface and run mach4 by the Api ,i cant compile as 64 bit ,because its then not work
is there any reason? or you think later will be change that i can compile also as 64 bit(we use onther libary 3d in same application
that bater use it with 64 ,so its important to us,not just theoratic question)

Offline smurph

*
  • *
  •  1,402 1,402
  • "That there... that's an RV."
    • View Profile
Re: Map surface wizard does not function
« Reply #5 on: March 17, 2021, 11:01:44 PM »
Mach is a 32 bit application right now, so anything compiled for it also needs to be 32 bits.  But running 32 bit applications on a 64 bit Win 10 OS works fine.  And when we implement a 64 bit application, you won't need to change your OS.  :) 

If you are using the IPC interface to control Mach from an external application, the new SDKs are shipping with a 64 bit IPC library.  So in that case, a 64 bit application can indeed control a 32 bit Mach. 

Steve
Re: Map surface wizard does not function
« Reply #6 on: March 18, 2021, 12:45:11 PM »
Hi KatzYaakov,

I think you run Mach4 in the background and you use C++ for the interface, so Mach4 is embedded within the controller interface right?

I also want to do this with the help of a node based application which also includes C++ programming, i am familiar with the basics of programming, of course need more than that for this but if you can tell me where to start or if there are any examples you can advice me i will be very glad and i am sure i can do it in time.

By the way in my case the problem is related with the mainboard of the controller its not accepting the drivers of the gpu anymore when i installed the new Win10 and Win7 OS the nvidia driver setup could not find the installed gpu and i couldnt be able to make it see the gpu through manual setup in device manager. My mainboard is Asus M4 series, i have 5 more dead M4 series mainboards from other computers so this one is dying too. I read that there is a problem in manufacturing these mainboard's pcbs and in time they die. So i am changing the gear, its a coincidence that it started to give errors when i tried the Map Surface wizard, thank you for the kind replies Steve.

regards,

Hakan