Hello Guest it is May 06, 2021, 05:14:40 PM

Author Topic: using mach 3 on older equipment using windows xp  (Read 94 times)

0 Members and 1 Guest are viewing this topic.

using mach 3 on older equipment using windows xp
« on: February 18, 2021, 01:06:30 PM »
I am trying to bring a plasma table back to life. Mechanically it's sound, drivers work and motors work. It uses a PDMX-122 interface/buffer through the 25 pin parallel port on an old desk top.

When I load mach 3 and jog the x and y outputs, the y axis works fine but the x axis step and dir signals appear on pin 6 and 7 on the parallel port ( I can measure the transition on pin 6 and 7 at the port on the computer) and this of course translates to the signal appearing on J3 on the pdmx-122 (connected to pins 6&7).  When I look into the Mach 3 config tab and go to the motor outputs, pins 2 and 3 are selected for the x drive, even though output appears on 6 and 7.

 I'm baffled . Can't figure it out.  Any ideas anyone? the PDMX-122 appears to be doing it's job, the output on the parallel port is weird.  I tried another computer and same result so I'm thinking maybe wrong version Mach 3? Im pretty sure everything is 32 bit.

Offline TPS

*
  •  2,122 2,122
    • View Profile
Re: using mach 3 on older equipment using windows xp
« Reply #1 on: February 19, 2021, 05:17:36 AM »
i would try to set up a new(fresh) Profile. it normal no big deal.
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.