Hello Guest it is April 12, 2021, 09:53:18 PM

Author Topic: PWM Laser output not responding to Sxx commands  (Read 143 times)

0 Members and 1 Guest are viewing this topic.

PWM Laser output not responding to Sxx commands
« on: December 29, 2020, 10:10:30 PM »
I have M11/M10 working really well now with appropriate g-code. But I still do not have PWM control of the laser output. I have attached screenshots of my current set up. I'm hoping someone here can pick out something that might be preventing my system from being able to regulate laser power with Sxx commands in the code.

It is my understanding that the Amp meter should reflect the output to the laser based on the Sxx command. No matter what I set for Sxx the amp meter does not change as shown below. It always reads right around 4.1 amps. The voltage meter on the control box show ~4.9 volts usually.

The PWM wire is wired to my BOB at pin 17, ground is set to Pin 18. The BOB is attached via ribbon cable to the output 3 of my ethernet smooth stepper(ESS). The BOB LED for pin 17 responds to input from MACH3, it is lit when there is signal and out when there is not.

One correction to the screen shots. In the main config my controller frequency is 250 Hz. This significantly improved timing of my laser. Also M11/M10 output mode is set to output 2 in my current set up.

In the THC control screen the base frequency is set to 3000 currently.

I have followed the endurance set up as well as the set up on the Warp9/ESS and can not find the error in my set up.

I'm hoping someone here can help me solve this issue for me.
I've added a video of my laser firing and pic of my voltage and amp meter.




Offline TPS

*
  •  2,102 2,102
    • View Profile
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: PWM Laser output not responding to Sxx commands
« Reply #2 on: December 30, 2020, 05:42:51 PM »
I have successfully set up mach 3 with PWM power control, M10/11 control of on/off and succesfully used the relays on the control box to prevent the laser from being ON when Mach 3 is turned off!!!! So stoked to finally get this working. Can't wait to start making cool stuff.  Once I got close, I think I just got lucky trying various combinations until I got what I wanted.







Ignore the burn marks from jogging I fixed this with the correct output in the M11/10 section of the main config.


« Last Edit: December 30, 2020, 05:48:16 PM by WhiteRoom Skis »