Hello Guest it is March 01, 2021, 06:43:39 PM

Author Topic: Machine Coords not zeroing...  (Read 336 times)

0 Members and 1 Guest are viewing this topic.

Offline Tweakie.CNC

*
  • *
  •  8,661 8,661
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Machine Coords not zeroing...
« Reply #10 on: December 18, 2020, 10:12:23 AM »
Yes, I already tried renaming the files as part of my initial posting (* -> *-Copy.xml/jpg).  That didn't help...

I don't already have "files of the same name" in my posting...  Is it possible that if ANYONE, ANYWHERE on this forum has EVER uploaded a file of the same name, this causes an issue?  Could that actually be the issue?  Am I just supposed to keep trying random file names until I find an unused one?  If so, this seems pretty stupid...

I will try again (with some really obscure filenames) once I get out to my shop in a few minutes...

Really stupid or not, that is just the way it is.

Take you file name and ad an a or a b or aa or aaa to the end of it, that will make it uique.

Tweakie.
KEEP SAFE !

Offline BR549

*
  •  6,944 6,944
    • View Profile
Re: Machine Coords not zeroing...
« Reply #11 on: December 18, 2020, 10:14:28 AM »
Sport you are NOT listening. We have already told you that you cannot reset teh Machine Zero manually in Mach3 or for that matter most other controllers as well.

Second YES you are correct you have to select a unique file name if you are going to post a file to this site. Most simply add their name to the filename "Test_File_Jackson.jpg" for example.

Just because you THINK your controller is fully compatible with Mach3 does not make it so. FEW  fareast controllers are fully compatible with Mach3. Yes they lied to you.

Your problem sounds like a switch bounce problem. You probably could solve the issue by adding some debounce to the input side. THAT IS IF your controller allows one to debounce the inputs.

(;-) TP

Re: Machine Coords not zeroing...
« Reply #12 on: December 18, 2020, 10:54:39 AM »
"Sport"?  Really?  Nice welcome to this forum...

Anyway here are the files renamed to something "unique"...

...and, yes, my controller appears to be working with Mach3.  I expect this is more of a "personal issue"...

There are videos out there specifically showing how to manually zero the machine coordinates.  (I linked to one in the OP).  Apparently, its the video that's lying to me and not my controller...

As previously suggested, I put manual zero'ing aside (as I'm being told its not possible) and focused on the "Ref All" function.  As machine coords seem mostly irrelevant for work, I wanted like my z-axis to zero "up" and not "down" so I can be sure to stay away from the spoilboard and any fasteners used to hold it to the work table.  Setting the "Home Neg" on the Z-Axis seemed to resolve that.  My spindle is no longer trying to dive into my spoilboard.

For anyone who is interested, I would like to say that it DOES appear that the little MX3 controller on the SainSmart/Genmitsu 3018-MX3 is working pretty well with Mach3.  Now I need to get working pretty well with Mach3...

Thanks!

Offline BR549

*
  •  6,944 6,944
    • View Profile
Re: Machine Coords not zeroing...
« Reply #13 on: December 18, 2020, 11:18:10 AM »
Yes teh video is lying to you. There is something about the machine shown that you are not aware of.  It has encoders linked to the table. Do you have table position encoders ??? Bet not.

NOW Zhome has nothing to do with Work zero.  Also you are setting yourself up for some aggrevation by setting up your machine to run Z backwards to what is normal . Having teh machine to home at the bottom has nothing to do with driving the bit into the table that can still happen no matter where Zhome is.

Just from 50 years of experience Z home is best setup at teh top of stroke in Z (top). That is as high as you can make Z move. Also known as safeZ as you can not make teh tool go any higher for clearance purposes. Also note that the tool tip position is also dependant on how LONG the tool is. To call that into play simply program G53 X0 and teh spindle will go to SafeZ (Zhome).

But it is YOUR machine set it up as you please (;-) But please do not complain when things go south for you.

(;-) TP

Re: Machine Coords not zeroing...
« Reply #14 on: December 18, 2020, 11:25:57 AM »
You'll note from my screen shots that I did not reverse the orientation of my z-axis.  As mentioned in my prior email, I just changed it to home "up" (at the of of the stroke as you suggest).  Changing the  "Home Neg" on the Z-Axis (on the "homing/limits config screen) is what now makes it home "at the top of the stroke" (vs at the bottom of the stroke as was the default).  It does not reverse the orientation of the z-axis.  I am not running it backwards...

...but thanks Buddy!  ;-)

Offline TPS

*
  •  2,004 2,004
    • View Profile
Re: Machine Coords not zeroing...
« Reply #15 on: December 18, 2020, 12:58:44 PM »
had a quick look to your Profile, Looks good so far.
try to increase Debounce Intervall in Config-> General Config
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Machine Coords not zeroing...
« Reply #16 on: December 18, 2020, 03:37:10 PM »
Nice!

Thanks!