Hello Guest it is April 17, 2021, 02:21:49 AM

Author Topic: NEED HELP Mach3 and 2HSS86H problem on AXBB-E  (Read 279 times)

0 Members and 1 Guest are viewing this topic.

Offline Alexi

*
  •  10 10
    • View Profile
NEED HELP Mach3 and 2HSS86H problem on AXBB-E
« on: September 21, 2020, 06:09:46 AM »

Hello,

Can anyone help i wonder?

I am trying to connect drivers to mach 3 to test them for first move but i harder then i thought.
Motor and encoder are wired according to label that is in motor.
This is the kit that i have: https://www.aliexpress.com/item/32802045718.html?spm=a2g0s.issue_5ptha.0.0.33334c4dEAMGhH

Configs that i am using are:
Pul+ Pin9
Pul- 5V0
DIR+ Pin19
DIR- 5V0

Switch in driver are config to default (400 steps)

Mach3 is config to 100 steps to mm velocity to 2000 and accel to 200. Step pulse and Dir pulse are both set to 5.
I believe AXBB-E is properly config because i have home induction switch and are working as supposed. I can activate them and mach3 is recognizing them

The problem is when i try to rotate motor in arrow keys i get driver error alarm and it blinks 7 times.
I tried several configs and kernel speeds but no success.

Any help is welcome.

Thanks
Alex

EDIT: Link corrected.
« Last Edit: September 21, 2020, 07:12:08 AM by Tweakie.CNC »

Offline reuelt

*
  •  487 487
    • View Profile
Re: NEED HELP Mach3 and 2HSS86H problem on AXBB-E
« Reply #1 on: September 21, 2020, 06:38:23 AM »
You also need to connect the ENABLE SIGNALS
ENA+
and
ENA-
"the gift of God is eternal life through Jesus Christ our Lord"

Offline TPS

*
  •  2,110 2,110
    • View Profile
Re: NEED HELP Mach3 and 2HSS86H problem on AXBB-E
« Reply #2 on: September 21, 2020, 06:44:53 AM »
btw your link is not working.
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline Alexi

*
  •  10 10
    • View Profile
Re: NEED HELP Mach3 and 2HSS86H problem on AXBB-E
« Reply #3 on: September 21, 2020, 07:04:36 AM »
Hi Reuelt,

Thanks for our help.

I believe i donĀ“t need to connect the enable signals because driver is enabled and motor shaft is locked when i start mach3. The problem is when i try to move axis it will only spin a small amount and driver gives error. Red led blinks 7 or 8 times not sure.
I tested all 3 drivers and same result for all.

Here is the link of my drivers
 https://www.aliexpress.com/item/32643410928.html?spm=a2g0o.productlist.0.0.4e0b738fSsKX2p&algo_pvid=b7c9c0ce-759a-49f1-abfe-a02615a2d6f8&algo_expid=b7c9c0ce-759a-49f1-abfe-a02615a2d6f8-10&btsid=0bb0623316006861580107870e66f0&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_

Thanks for all
Alex

Offline TPS

*
  •  2,110 2,110
    • View Profile
Re: NEED HELP Mach3 and 2HSS86H problem on AXBB-E
« Reply #4 on: September 21, 2020, 07:07:57 AM »
have you tryed to Change Motor direction by swapping A and B wire's ?
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline Alexi

*
  •  10 10
    • View Profile
Re: NEED HELP Mach3 and 2HSS86H problem on AXBB-E
« Reply #5 on: September 21, 2020, 07:32:51 AM »
You mean motor coils?

Change A+ to B+ and A- to B- ?

Thanks
 

Offline TPS

*
  •  2,110 2,110
    • View Profile
Re: NEED HELP Mach3 and 2HSS86H problem on AXBB-E
« Reply #6 on: September 21, 2020, 07:34:44 AM »
yes exactly, because i think rotation of Motor and Feedback does not match.
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline Alexi

*
  •  10 10
    • View Profile
Re: NEED HELP Mach3 and 2HSS86H problem on AXBB-E
« Reply #7 on: September 21, 2020, 07:49:07 AM »
Oh ok i will try that and post for results.

Thanks

Offline Alexi

*
  •  10 10
    • View Profile
Re: NEED HELP Mach3 and 2HSS86H problem on AXBB-E
« Reply #8 on: September 22, 2020, 01:01:46 PM »
IT WORKED.

It looked like magic, all issues were gone, thanks.

Alex