Hello Guest it is October 24, 2021, 11:36:24 AM

Author Topic: NEED HELP!!! Setting up Mach3 with Gecko G320X and servos for a 3-axis router?  (Read 650 times)

0 Members and 1 Guest are viewing this topic.

Hello, I am new to the forum and also to using Mach3. I recently undertook the task of setting up a 3-axis K2 router equipped with servos and new Geckodrives G320X. I am having trouble setting up mach and getting it to communicate with the servos. The drives were previously installed by someone else and I dont know which ports and pins to designate on Mach. Does anyone have a complete rundown or tutorial to set up something like this? I am basically starting from scratch here and dont have a clue as to what to do. Any info would be much appreciated.

Offline TPS

*
  •  2,202 2,202
    • View Profile
Pictures, Pictures, Pictures.

anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline ZASto

*
  •  387 387
    • View Profile
Which controller are you using?
As tps wrote, some *********ography please :D
Make no mistake between my personality and my attitude.
My personality is who I am.
My attitude depends on who you are.
I’ll get some pics up right now.
Need help! K2 router problems!
« Reply #4 on: September 15, 2020, 01:36:45 PM »
Does anyone know what breakout board comes in the K2 router control box?? Im trying to configure mach3's ports and pins and I have no clue what my inputs and outputs are. Ive tried contacting K2, they seem to be out of business. I really need to know what breakout board they used. The control box has gecko drives G320X's and the router has servos on all 3 axis. What should I do and where should I start?

Offline Graham Waterworth

*
  • *
  •  2,394 2,394
  • Yorkshire Dales, England
    • View Profile
Re: Need help! K2 router problems!
« Reply #5 on: September 15, 2020, 05:15:06 PM »
Lots of pictures for us to asses first.
Without engineers the world stops
having trouble uploading my photos... However I have another question. The PC that was previously running mach3 for this router crashed and lost all the configuration settings. Would downloading Mach3 on another PC automatically configure my settings for this router? Like the Ports/pins?

Offline TPS

*
  •  2,202 2,202
    • View Profile
Quote
having trouble uploading my photos.

is itrealy so hard to to click the  "Attachment and other Options" Botton?

Quote
.. However I have another question. The PC that was previously running mach3 for this router crashed and lost all the configuration settings. Would downloading Mach3 on another PC automatically configure my settings for this router? Like the Ports/pins?

NO all the configurations are stored in one file, called "C:Mach3\your profilename.xml"

BTW: all our completly unimportant questions about further detailed informations have not been answered.
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.
First off idk what a "botton" is. Secondly, every time I attach photos and click post nothing happens. Photos are the correct size and format.
1