Hello Guest it is May 07, 2021, 12:49:44 AM

Author Topic: Unable to limit feed rate on Z axis..What am i doing wrong?  (Read 250 times)

0 Members and 1 Guest are viewing this topic.

This is a DYI plasma table using the little red Langmuir controller. {USB Motion Controller}

Under Motor Tuning i have the X and Y axis set to 200ipm max velocity. I have the Z axis set to 50ipm.

The problem arises when i run G-Code. The Fusion Mach3 post doesnt allow me to specify a seperate Z axis feed rate, so it sets it at the same 180ipm i want to be cutting at. Problem being the axis cant move that fast and stalls during each commanded Z move. I cant find a way to get Mach3 to limit this. If i go to Jog and the feed rate is set to 200 it will only jog at 50 on that axis like it should. But when running under g code it seems to try to run at whatever feed it commands and just stalls.

Is there a setting? am i doing something wrong? glitch in the matrix?

Re: Unable to limit feed rate on Z axis..What am i doing wrong?
« Reply #1 on: July 30, 2020, 05:50:22 PM »
Unchecking the boxes in CV options seems to have cured it?

Will see if that was a valid fix or its a glitch in the software.
Re: Unable to limit feed rate on Z axis..What am i doing wrong?
« Reply #2 on: July 30, 2020, 10:14:29 PM »
Alright the issue is back. Sometimes it will work on one line of code and not work on another line in the same program.

Mach3 is sometimes limiting the Z axis motor to the speed in motor tuning and sometimes not.

I sure am glad i paid for this buggy pile of ********* with no support.

Offline Tweakie.CNC

*
  • *
  •  8,704 8,704
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Unable to limit feed rate on Z axis..What am i doing wrong?
« Reply #3 on: July 31, 2020, 03:04:55 AM »
Alright the issue is back. Sometimes it will work on one line of code and not work on another line in the same program.

Mach3 is sometimes limiting the Z axis motor to the speed in motor tuning and sometimes not.

I sure am glad i paid for this buggy pile of ********* with no support.

It's understandable and I suppose you have to blame somebody but in your case Mach3 is just acting as the Motion Planner the actual and true control of your machine is all handled by your Langmuir Motion Controller.

Tweakie.

EDIT; Additional information.

Quote
I have the Z axis set to 50ipm.

Reduce your Z axis Velocity in Motor Tuning to 39 and save the change.
« Last Edit: August 01, 2020, 01:20:31 AM by Tweakie.CNC »
KEEP SAFE !