Hello Guest it is December 09, 2019, 04:55:14 PM

Author Topic: Why won't the pins go low?  (Read 6574 times)

0 Members and 1 Guest are viewing this topic.

Why won't the pins go low?
« on: September 29, 2007, 05:38:28 PM »
Hello all.  My router table is finished and ready to go!  I have the controller card installed, Mach3 (and TurboCNC as a backup) both trying to get it to come to life, but there's no joy!

My controller card needs pins 8, 9, and 14 to be low to "activate" the three axes, and it steps/dirs with 2-3, 4-5, and 6-7 which seems pretty standard.

As a troubleshooter, I have a great little program that shows every pin of my LPT port and lets me toggle it high or low by clicking on it.  If you'd like it, it's available at http://www.geekhideout.com/parmon.shtml.

By doing so I can enable each axis individually, change its direction, and step the motor attached to it.

What I CANNOT do is get Mach3 (or TurboCNC) to activate the axes and step/dir them.  No matter WHAT I enter into the configs...  I've been through the Mach tutorial five times and I've swapped the Active Low settings for grins, and and and - no joy :(

What the heck could I be doing wrong?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Why won't the pins go low?
« Reply #1 on: September 29, 2007, 05:59:34 PM »
Do you have the correct port address set? Do you have the correct port number in the Motor Outputs page for each axis?

Hood
Re: Why won't the pins go low?
« Reply #2 on: September 29, 2007, 08:56:36 PM »
Thank you for responding.  Yes, I have the proper port number (with the proper address per Device Manager) and I have the proper pin numbers on each screen, including for X, Y, Z, Enable 1, Enable 2, and Enable 3, and I have double-checked all of the Active Low settings (as well as toggling them in an attempt to get them to work.)

I changed the parallel port from Bidirectional to ECP with no effect.  Some forums say to use SPP but I don't have that as an option...

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Why won't the pins go low?
« Reply #3 on: September 29, 2007, 09:28:03 PM »
Hi, Tamathumper

Are you checking for Low/High at the Stepper board ?

Check your Cable, Are pin's 1 to 1, 2 to 2 & so-on to 25, 25, Could be your using a Serial Cable and not a Printer extender cable ?

Some printer cards, cables and cnc boards don't support/use all the same Gnd pins 18 through 25, Thy just use a couple of them.

Check that you have a good Gnd from the computer and your cnc board.

I've seen these a couple of times

Hope this Helps, Chip

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Why won't the pins go low?
« Reply #4 on: September 30, 2007, 04:33:23 AM »
Why are you using the Axis enable  - they should be on anyway. On my drive cards each axis can be turned on or off by switching a switch on the card, or connecting an external signal to an input.

Switch the axis on at the card and leave it on - it has to be on anyway. I happen to have my external connections to switches on the control box so I can turn each axis on and off manually if I need to ( I have a lathe with a milling head - so I turn the milling axis off so power does not go through the stepper all the time).

You should find that when you attach Mach3, it will work. You are just making things complicated.
I cannot remember if Mach3 automatically puts out an enable signal  on the Enable pins or not. You would have to tell Mach 3 which pins you are using as enable pins anyway - on the Ports and Pins config if you wanted to use them.
Not me driving the engine - I'm better looking.
Re: Why won't the pins go low?
« Reply #5 on: September 30, 2007, 06:35:10 AM »
Has a similar problem. Motors ran using other software but could not get Mach 3 to run the motors until I activated the "Gecko half step mode" on the Config->Motor and pins tab

Hope this helps ::)

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Why won't the pins go low?
« Reply #6 on: September 30, 2007, 06:42:09 AM »
conroydb
 Are you meaning the Sherline Half Pulse mode?

Hood
Re: Why won't the pins go low?
« Reply #7 on: September 30, 2007, 08:04:44 AM »
Hi, Tamathumper

Are you checking for Low/High at the Stepper board ?

Check your Cable, Are pin's 1 to 1, 2 to 2 & so-on to 25, 25, Could be your using a Serial Cable and not a Printer extender cable ?

Some printer cards, cables and cnc boards don't support/use all the same Gnd pins 18 through 25, Thy just use a couple of them.

Check that you have a good Gnd from the computer and your cnc board.

I've seen these a couple of times

Hope this Helps, Chip

Thank you very much Chip.  I appreciate your tips!  When I run Mach, I can see the hi/lo state of each pin, and they are not what I am assuming Mach should set them to - that is the real problem I think.

If I click on each pin to change its hi/lo state, I can force each axis to enable/disable, I can change the direction of each axis, and I can force each axis to make a step.  Because I am able to do this from the computer, I am assuming that the cable is good and that the grounds are appropriate.

First and foremost, I just can't understand why Mach is not setting the pins automatically to enable the axes...
Re: Why won't the pins go low?
« Reply #8 on: September 30, 2007, 08:08:46 AM »
Why are you using the Axis enable - they should be on anyway. On my drive cards each axis can be turned on or off by switching a switch on the card, or connecting an external signal to an input.

Switch the axis on at the card and leave it on - it has to be on anyway. I happen to have my external connections to switches on the control box so I can turn each axis on and off manually if I need to ( I have a lathe with a milling head - so I turn the milling axis off so power does not go through the stepper all the time).

You should find that when you attach Mach3, it will work. You are just making things complicated.
I cannot remember if Mach3 automatically puts out an enable signal on the Enable pins or not. You would have to tell Mach 3 which pins you are using as enable pins anyway - on the Ports and Pins config if you wanted to use them.

Jim,

Thank you very much for responding!  I certainly tried for a day or two to get the axes configured and working before I even attempted to use the enable features of Mach (I didn't know they existed.)  The problem is, Mach does not put those pins low by itself, and it also does not put those pins low even when I specify them in the setup.  Without those pins being low, the axes are not enabled on the machine, so I just set them as part of yesterday's troubleshooting.  I'd love to keep it simple, in fact Simplicity is one of my mantras, but in the process of troubleshooting why Mach will not set the pins appropriately and drive my motors, I have had to try all avenues.
Re: Why won't the pins go low?
« Reply #9 on: September 30, 2007, 08:17:39 AM »
Sherline Half Pulse mode?  What would this do?