Hello Guest it is April 13, 2021, 10:50:43 PM

Author Topic: TOOL CHANGE ISSUE  (Read 491 times)

0 Members and 1 Guest are viewing this topic.

Offline Graham Waterworth

*
  • *
  •  2,305 2,305
  • Yorkshire Dales, England
    • View Profile
Re: TOOL CHANGE ISSUE
« Reply #10 on: May 06, 2020, 07:46:58 PM »
Is the run time clock counting when you think its hung, it was working here but it took it a while to go from tool 1 to 2 and 2 to 4 and back to 1

Has this ever worked correctly.

Some pictures of the setup may help and a description of the tool changer function.

Go into the macro folder and delete all the .mcc files.

« Last Edit: May 06, 2020, 07:56:18 PM by Graham Waterworth »
Without engineers the world stops
Re: TOOL CHANGE ISSUE
« Reply #11 on: May 06, 2020, 09:44:26 PM »
Yes the cycle timer is running . After 5 mins I shut Mach  down . I have only used the the toolchanger in MDI.  This is my first attempt to try it in a program . I have given up trying to make it go from 2 to 1 .The machine is a lathe  Dyna Myte DM300 .Im using a cnc4pc m16 d with a pokeys 57e core board .The turret is gear driven by a nema 23 stepper motor . The motor drives a right angle gear set up . it is locked up against a pawl  .The lock can be released by a solenoid .I have the solenoid connected to a relay tied to output 21 .I also have a software button that can toggle the relay that operates the solenoid .  To go from 1 to 2 the  solenoid is not needed it is only needed when going to a lower numeric number like from 2 to 1 . So I gave up on making that work when I discovered I cant change tools from a program .The turret moves clockwise when going from one to 2 . It passes the lock position then the turret backs up against the lock. To release the lock the turret motor has to rotate the opposite direction 1/16 of a motor revolution or so just enough to take the pressure off the pawl so the solenoid can pull up , then back the other way to complete the tool change .So when I gave up on that this other problem was discovered.  I think this week end I will install the latest version of Mach and try to find on of the old Macros and try that .Thank you sir.
Re: TOOL CHANGE ISSUE
« Reply #12 on: May 09, 2020, 12:00:09 PM »
I would like to thank everyone who helped me .I figured out that its the M5 code causing the problems .Don't know how this wasn't caught .But when my system sees it ,,it stops everything .The spindle  , motion   Mach . Is this a bug...? I thought M5 just stops the spindle ?