Hello Guest it is May 09, 2021, 10:10:31 AM

Author Topic: Toggle Button not clickable  (Read 361 times)

0 Members and 1 Guest are viewing this topic.

Toggle Button not clickable
« on: July 12, 2020, 07:23:17 AM »
Hello, I have modified the standard lathe screen with a toggle button to the right of the g-code box. When I made this button with the screen editor and then closed the editor it worked without fail. When I re-loaded mach4 I was unable to click on the button, it was not greyed out, it just wouldn't let me click.

When I open and closed the editor again the button worked. This is a continual pattern of behaviour, as I open Mach4 the button doesn't work, if I open and close the screen editor it then works.

Does anyone know what would cause this behaviour and how to fix it?
Re: Toggle Button not clickable
« Reply #1 on: July 13, 2020, 12:40:44 PM »
Hi,
sorry das in deutsch antworte. Mein englisch ist sehr schlecht.
Ich weis nicht ob ich die Frage richtig verstanden habe?
Ist der Button auch aktiviert? (Enabeld)
Vielleicht hilft das weiter?

Gruß Thomas

Re: Toggle Button not clickable
« Reply #2 on: July 13, 2020, 04:36:52 PM »
Thanks for the reply. Google Translate is excellent.
The button is enabled. It has all of the same settings that the reset button does which works all the time.

I have also clean installed mach4 on my main computer to see if it was a problem with the install instance. The problem occurs on both computers.
Re: Toggle Button not clickable
« Reply #3 on: July 14, 2020, 04:34:11 PM »
I think I need to further clarify my previous post. The enabled property for the button is selected, and has been the whole time. It still does not work.

This is quite frustrating.
Re: Toggle Button not clickable
« Reply #4 on: July 15, 2020, 01:01:44 PM »
It would probably help if you posted a screen snip of all of the properties and one of the script code as well.
Re: Toggle Button not clickable
« Reply #5 on: July 15, 2020, 04:54:06 PM »
I have attached the properties and events tab for the button. I'm not sure what script you're after? Am I meant to have written a script to accompany the button?

You help is much appreciated.
Re: Toggle Button not clickable
« Reply #6 on: July 16, 2020, 11:29:52 AM »
Could not replicate the error.  I named it and set all properties the same as yours.  Worked as expected even after shutting down and restarting.  The only thing I couldn't replicate is the color Silver but I wouldn't think that has anything to do with it.  Have you tried deleting it and adding another toggle button?

HTH
RT
Re: Toggle Button not clickable
« Reply #7 on: July 16, 2020, 04:28:23 PM »
Thank you very much! You are a legend!

I feel like a complete idiot that I didn't delete the button and try it again, but that is all it took. So much wasted effort reading the screen building guide and playing with properties etc.

I've tried it on both my normal computer and my lathe controller and they both work.

Again, thankyou very much.