Hello Guest it is May 14, 2021, 02:43:56 AM

Author Topic: Mach 4 homing  (Read 650 times)

0 Members and 1 Guest are viewing this topic.

Offline Laz

*
  •  12 12
    • View Profile
Re: Mach 4 homing
« Reply #10 on: March 29, 2020, 03:42:54 PM »
The problem I countered is 
If I take out the check mark on axis mapping from axis A  (motor3) so it is disabled the that motor won't even jog in any direction with motor0
If i take it out of homing order ( change it to 0 from current 2) doesn't change anything ether   

 

Offline Laz

*
  •  12 12
    • View Profile
Re: Mach 4 homing
« Reply #11 on: March 29, 2020, 03:45:39 PM »
I thought about the plug in problem
i guess i may have to bite the bullet and get an ESS

Thank you very much

Laz
Re: Mach 4 homing
« Reply #12 on: March 29, 2020, 05:56:24 PM »
Hi,
You don't have a freakin' A axis, that is your Mach3 thinking. You've been told three times, once by Steve
and twice by me to remove all reference to the A axis. This makes the fourth....

There should be no motor assigned  to the A axis and it should not be enabled.

On the Homing/SoftLimits page the home order of the A axis should be zero, ie it does not home at all.

On the InputSignals page the MotorHome0 though MotorHome3 should be populated with there respective
home switch input pins, per my previously posted screen shot.

If it does not work thereafter I can only conclude the XHC doesn't support slave  motors...surprise surprise!
If that's the case you can try contacting XHC, and good luck with that, OR buy yourself an ESS, it works as advertised
and Andy (Warp9 Tech Rep) is on-line 8 hours a day 5 days a week for support.

Craig
My wife left with my best friend...
     and I miss him!

Offline Laz

*
  •  12 12
    • View Profile
Re: Mach 4 homing
« Reply #13 on: March 29, 2020, 06:16:14 PM »
Thank you Craig

I will try but already orders an ESS

Thank you again an I'll let you know how it goes

Laz