Hello Guest it is May 16, 2021, 02:11:11 PM

Author Topic: M10 and M11 commands with Mach 3 and UC300ETH  (Read 340 times)

0 Members and 1 Guest are viewing this topic.

M10 and M11 commands with Mach 3 and UC300ETH
« on: March 24, 2020, 09:57:45 AM »
I recently added a Laser to my DIY CNC machine and have run into a few issues and I think Tweakie can probably help here after reading a lot of his posts and his fantastic website.
I used to run with the ESS controller but kept having all sorts of errors "Bootloader" and "run out of memory" so switched to the UC 300ETH controller card and it has been fantastic with he milling side of things. I stuck with Mach 3 as it had already plugins available for my wireless pendant and modbus for the VFD. I still have my ESS and use it for just testing purposes on my bench and have used it to prove the functionality of the on off spindle control and PWM out of the ESS.
The issue I'm having is that there is no plugin configurable for the M10 and M11 commands within the UC 300 ETH plugin within Mach 3 and I think that is where to problem is.
I have just created a test piece of Gcode from Inkscape and when I run it with the ESS it works flawlessly but when I run it with UC 300ETH it only runs the first 2 lines of the Gcode then stops.
I'm attaching the Gcode so someone can confirm my findings don't worry about the poor visuals this is just a test nothing more.

Offline Tweakie.CNC

*
  • *
  •  8,706 8,706
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: M10 and M11 commands with Mach 3 and UC300ETH
« Reply #1 on: March 25, 2020, 03:03:28 AM »
Hi Formantjim,

I just tested your Gcode and had the same result as you.

It doesn't solve the problem but your Gcode really needs an M3 at the start (to enable the M10P#/M11P# commands).

I have sent you a PM.

Tweakie.
« Last Edit: March 25, 2020, 07:54:17 AM by Tweakie.CNC »
KEEP SAFE !