Hello Guest it is July 12, 2020, 04:41:35 PM

Author Topic: Schrittverluste mit Mach3 und Tripple Beast  (Read 116 times)

0 Members and 1 Guest are viewing this topic.

Schrittverluste mit Mach3 und Tripple Beast
« on: January 20, 2020, 12:52:07 AM »
Guten Morgen zusammen,


Ich hatte am Wochenende paar Probleme mit meiner Fräse.
Wenn ich mit dem Handrad verfahre laufen alle Achsen ohne Probleme.

Wenn ich allerdings die X Achse dann im MDI per G Code verfahre (G1 X20 F400 z.b) habe ich Schrittverluste (Also der Stepper heult auf und es bewegt sich gar nichts mehr). Es schein nur dann ein Problem zu sein wenn ich die Richtung der Achse umdrehe von zuvor in +x verfahren auf -x. Es ist egal mit welchen Vorschub. Selbst mit nur 400mm/min passiert das. Ich dachte schon die beschleunigungs Rampen sind zu steil aber die habe ich schon auf 50 mm/s2 heruntergedreht und es ändert nichts dran.
Wenn ich am USB Handrad verfahre gibt es keinerlei Probleme mit Schrittverlusten. Die Achse verfährt ohne zu murren, bis rauf auf 1000mm/min, selbst bei Richtungsänderung...

Ebenfalls habe ich schon die Backlash Geschwindigkeit auf 30% von Max (1000mm/min) runtergedreht.  Gleiches Problem.

Die Fräse lief zuvor eigentlich Problemlos.
Das einzige was ich geändert hab ist, dass ich eine 4 Achse drangehängt habe.

Hat jemand eine Idee woran das liegen könnte?


Noch paar Infos zum System. Fräse ist eine umgebaute Paulimot F207V mit Nema 23 Stepper. ESS und Tripple Beast Steuerung. Mach läuft auf einen ziemlich nackten win XP Rechner.


Danke schonmal

Beste Grüße
archer

Re: Schrittverluste mit Mach3 und Tripple Beast
« Reply #1 on: January 20, 2020, 01:29:19 AM »
sorry. i was still  a bit tired and wrote everything in german... new post in englishc is up...

Offline Tweakie.CNC

*
  • *
  •  8,356 8,356
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Schrittverluste mit Mach3 und Tripple Beast
« Reply #2 on: January 20, 2020, 02:05:01 AM »
 ;)

Tweakie.
KEEP SAFE !