Hello Guest it is February 07, 2023, 06:22:33 AM

Author Topic: mach3 demo with windows7 64 bit system cant get stepper motor to work  (Read 1689 times)

0 Members and 1 Guest are viewing this topic.

Offline dlang

*
  •  10 10
    • View Profile
Down loaded mach3 demo with windows7 (64bit system) cant get stepper motors to work. Do I need a license to get steppers to work or is it that the its not a 32 bit system. New to cnc routing.  thanks
Hi,
because you have a 64bit OS you will require an external motion controller like an Ethernet SmoothStepper or a UC300.

If you want to use Machs parallel port (no extra hardware required) then you MUST use a 32bit OS Windows7 or  earlier.

Craig
My wife left with my best friend...
     and I miss him!

Offline dlang

*
  •  10 10
    • View Profile
Hi Craig
Thanks for the info. This cnc router is new to me . Appreciate the help.

Offline dlang

*
  •  10 10
    • View Profile
Hi
 Have now installed windows7 with 32 bit operating system. Still have not been able to get the stepper motors to run. Now when going into mach3 it locks up cant do anything. Basically have to turn the computer off to get out of mach3.  Also I have mach3 demo does this have anything to do with the stepper motors not working. I have not bought a license yet! Would this have anything to do with the stepper motor not working. Not sure what to try next.

Offline ZASto

*
  •  414 414
    • View Profile
You should be able to run demo, as far as I know, demo is limited ti 500 lines of code (50 in turning).

Have you installed all relevant drivers for your hardware?
Did you try to run DriverTest? It is locateed in Mach3 folder.
Make no mistake between my personality and my attitude.
My personality is who I am.
My attitude depends on who you are.

Offline Tweakie.CNC

*
  • *
  •  8,978 8,978
  • Super Kitty
    • View Profile
If you are using a 64bit PC then I doubt that you will be able to use the Parallel Port drivers even if your OS is 32bit.

Tweakie.
PEACE

Offline dlang

*
  •  10 10
    • View Profile
Hi
Did get the motors to work . I did have the parrellel port address wrong.Instead of 378 .I had to put in d880 which got the stepper motors to work.Started to connect the motor to the machine. then later in the day I lost the connection some how . Didn't change a thing. Did notice that when I shut the computer down and restart computer back up . That the motors did have power to them. Because when the computer started up I would try turning the motor and I could feel that I could not turn them. Then when I went into mach3 program the motors lost power by  trying to turn them ,I could turn them easy. When in mach3 I would use the key board to use the arrow for all motor movement. The motors would not move but the green light would light on the driver board but the motor would not work. Not sure what I have wrong. But I did get the motor to move at one time so things are getting better. I did also install windows 7 with 32 bit os  thank for all the help you people give. I appreciate it.
« Last Edit: May 27, 2020, 08:50:18 AM by dlang »
Hi,
Mach's parallel port wold run on one (32bit) PC well but not on another (32 bit) PC without any ryhme or reason.
The simple expedient is to get an external motion controller like an Ethernet SoothStepper.

Thereafter you can use just about any PC, 32 or 64 bit, any Windows OS from XP through Windows 10, and laptop
or desktop. In addition Mach will be less inclined to stutter or stall with other software on the PC being either installed
or running, alway a definite no-no with a parallel port.

The $180 cost of an ESS is the best single improvement I ever made to my machine,

Craig
My wife left with my best friend...
     and I miss him!
Re: mach3 demo with windows7 64 bit system cant get stepper motor to work
« Reply #8 on: December 02, 2020, 03:16:33 PM »
Yup,

I agree with what @joeaverage said. This happened to me as well. Since I had 64bit OS I needed an external motion controller. I used a UC300.

- Matt