Hello Guest it is January 26, 2020, 10:55:31 PM

Author Topic: Threading Problem When Changing Motor Speed! WEIRD  (Read 90 times)

0 Members and 1 Guest are viewing this topic.

Threading Problem When Changing Motor Speed! WEIRD
« on: November 26, 2019, 05:42:15 PM »
Ok so I've got a 1978 Mori Seiki Lathe that I rebuilt and redid all the electronics and programming. Works well. Now I usually only cut short thread, 1/2" - 3/4" long, and usually 1/4-20. Then over the last few days I've been making a lot of parts using the machine for like 12 hours a day. I've always had some weird quirks with this machine and the Mach Motion built in wizards, see other posts in you're interested.

To make a long story short sometimes I have missed steps, whatever you call in with servos, so using the machine a lot lately I'm running into the problem more frequently. The machine loses steps when moving short distances using rapid. So at the end of cut when the tool goes back to X.75 Z0 (the beginning of the part) then back to home. So I figured I never cut at full speed I'll slow the servos down. I went from 80 Velocity and 20 Acceleration to 40 Velocity and 5 Acceleration to see if that was the problem. Didn't completely work, but worked well enough. The motors, mind you, were still smooth running.

So then I went to cut some 1"-8 threads that I was cutting the day before and the thread pitch was WAY off. More like 1"-20. I have no idea of why this would change anything. I just changed the motor speeds not the steps per inch.

Can anyone tell me what the deal is and how to correct this. Looking back to a couple days ago I noticed that the first 1/2" of the 1"-8 threads were pretty dam close, but 1" further down the pitch was off. I figured it was my original ball screw which is execllent, but NOT perfect. So now I realize that the pitch being off was not the ball screw but the motor speeds. As a side note when cutting lengths on Z the measurements are alwasy accurate.
Re: Threading Problem When Changing Motor Speed! WEIRD
« Reply #1 on: November 26, 2019, 06:55:55 PM »
Hi,
may I suggest splitting the experiment up a bit.

You say you are threading and so it could be that your servos are being inaccurate and 'losing steps'. Surely though you would have noticed this before.
If your motors are losing steps they would be doing it on all machining operations, not just threading.

When threading you are relying on the motion controller to control the z axis motor speed to stay in synch with the spindle. I suspect that is the issue here,
not that the motors are losing steps but that the motion controller is in-accurately specifying the motor revs. Even more likely is that just before
a cutting pass the spindle might be doing 500 rpm and so the controller specifies that the Z axis motor do 78.56 rpm say, to execute a threading pass of the
correct pitch. When the cutting comenses the spindle will slow a bit (to 450rpm say) but the controller is maintaining it spec of 78.56rpm for the Z axis, hence
the apparent  inaccuracy of thread pitch.

Can you think of or devise some test to determine if the controller is altering the Z axis revs to match the acutal spindle speed. If it updates its Z axis rev
command.....how often?

Craig
My wife left with my best friend...
     and I miss him!
Re: Threading Problem When Changing Motor Speed! WEIRD
« Reply #2 on: November 26, 2019, 07:17:02 PM »
So I'm not so concerned with the losing of steps, I mean I am, but it really, for the most part happens at the end of threading when it does a quick move from the starting position of the part to home which is where tool changed occur as it's an auto tool changer. I've tried figuring this out before years ago and got nowhere. I think one of the Mach Motion guys responded and couldn't figure it out.

I think the quick motion, acceleration?, is the culprit, not sure why. I should be changing my G-code so the rapids are a lot lower.

I only mention all of this to explain why I changed the speed of the motors.

Now having said that the threads are not the correct pitch I speciifed, but they are consistent.

What you said made sense, I lowered the speed of the motors and so the controller pushed them as fast as they could, but they couldn't go fast enough for the large threads I was cutting.

I'll try to re-run the threads at a lower RPM, I was doing 600 RPM because it was HDPE.