Hello Guest it is February 28, 2021, 01:18:57 AM

Author Topic: trouble with touch probe - Port 1 pins current state not showing (cnc 6040)  (Read 963 times)

0 Members and 1 Guest are viewing this topic.

Hi all :) used many hours and now I need help! I've got a CNCz 6040 China Machine, Mach3 and a windows 7 computer.
I can move my cnc, run programs and stuff- spindle works, but when I go to Mach3 Diagnostics there are no green lights showing at Port 1 pins current state? How is that? I ran a monitor program to check my ports activity and could see there were some ports that were red and some were green.

Well all this began because I wanted to use my touchplate probe... I can press the auto tool zero button- but I doesn't stop it movement down the z-axis when it touches the plate. BUT----I can only use the auto tool zero if I have my active low unchecked- as soon as I check the active low setting in ports and pins input for the probe it doesn't work. I can see the digitize light is green when active low enabled. And it doesn't flash or turn off when i test the probing plate. What is wrong? Could it be a missing ground connection in the controller box for the probe? Or electrical noise? Or my setup? A bios thing with printer port?

I know the CNC 6040 are not the best built machines, but it is all I could afford  ::) I hope I dont need to solder stuff and rewire, as I am not so proficient in electrics.

Kind regards
Christian Bang Jensen

Offline kak

*
  •  81 81
    • View Profile
Isn't it the same machine as yours? 
https://www.youtube.com/watch?v=tvV2Vmrxarc
Yes it is  ::)

And I also use the same script as him ( and I have written to him, but I guess a lot of people do)...but  after following his instructions, I very early on get the problem with the digitize light being either on all the time, as if the probe is being activated continuously or the digitize is off and the z-axis dont stop when it reaches contact with probe.

I am guessing it could be my controller that is the issue! I've got it hooked up to windows 7 computer via usb controller card named  XHC NcUsbPod- guessing a USB controller doesn't use pins?

Still a newbie, so I might be asking the wrong questions

Offline kak

*
  •  81 81
    • View Profile
I'm also a kind of newbe.  Made my machine work 8 years ago and didn't touch anything since :-)
The Digitize light must be on when you touch the probe, and off if you don't touch it.  The light/led should also work without the script, in Diagnostics.
Port 1 pins current state - I have only 1 green light, out of 24 and my machine is working.   
Did you read the information ?
"Note that Mach3 versions below  R3.043.066 may not run the script correctly due to several unsupported Cypress Enable script functions.
Also note that you may have to disable Mach3's Z_Safe feature for the script to run correctly. "

The script may refer to another (older) version of Mach3. 

There is also more her  https://hl-yeah.com/2017/08/04/chinese-commercial-cnc-wood-router-engraving-machine-xhc-usb-motion-controller-mach3-download/
Thanks :) it worked! I had to look at another manual than the one I got...so I changed pin to 4 instead of 15- so now it works- now I am on to the problem of a non-functioning pump ;D