Hello Guest it is January 26, 2020, 10:56:43 PM

Author Topic: New mach4 ERROR's after install  (Read 649 times)

0 Members and 1 Guest are viewing this topic.

Offline gorf23

*
  •  138 138
    • View Profile
New mach4 ERROR's after install
« on: October 26, 2019, 07:42:28 PM »
Been getting some errors in the history, when mach4 boots never had them till the newest mach4 install.

I attached the history file..

Thanks
Gary
 

Offline jevs

*
  •  306 306
    • View Profile
Re: New mach4 ERROR's after install
« Reply #1 on: October 26, 2019, 08:40:20 PM »
Are you using an ESS?

Check version compatibility. I got similar issues when I tried to go to one of the newest Mach versions from the FTP page. The current ESS compiles and works with one that is not the newest.

I am now using
Mach 4.2.0.4310 & ESS v248

I believe this combo was tested to compile by Warp9. A newer version of Mach gave me errors at bootup with V248 like you see.

https://warp9td.com/index.php/gettingstarted/setting-up-the-smoothstepper-and-mach4#MachFourInitialESS_NEW_PLUGIN

STEP 3

However....I see now they have ESS Mach4 Plugin, build 250. (compiled against Mach4 v4322)...I just updated everything a few days ago LOL. Looks like I will be doing it again.

Offline gorf23

*
  •  138 138
    • View Profile
Re: New mach4 ERROR's after install
« Reply #2 on: October 26, 2019, 09:57:09 PM »
Don't think its the ESS at this point, I did have it installed.. v250

But I have uninstalled mach4 removed any thing I can find in the reg's that wasn't removed, then I reinstalled mach4
no plugins installed and getting the same error, funny thing is I only get it with the mill profiles miil4axis and mill6axis.
the lathe and others don't give any errors..

Gary

Offline jevs

*
  •  306 306
    • View Profile
Re: New mach4 ERROR's after install
« Reply #3 on: October 26, 2019, 10:36:03 PM »
so you have ESS v250 and Mach4 v4322 ?

I just installed both of those and mine boots up fine. On a mill...

Offline thosj

*
  •  376 376
    • View Profile
Re: New mach4 ERROR's after install
« Reply #4 on: October 27, 2019, 08:35:20 AM »
I really have no idea, but VERTEX SHADER leads me to think video driver, GLSL is Open GL, video stuff. Maybe try installing the latest driver for your video card? I've also heard of issues with onboard video in some PC's also, but if it worked before, that MIGHT rule THAT out.

Tom
« Last Edit: October 27, 2019, 08:37:46 AM by thosj »

Offline gorf23

*
  •  138 138
    • View Profile
Re: New mach4 ERROR's after install
« Reply #5 on: October 27, 2019, 10:15:35 AM »
I installed the newest video drivers but no change..

I uninstalled all again and installed mach4 ver 4310 and all is good with this version..

if i try to upgrade it to the newer version, the install seems to stop 1/4 of the way though first try and i have to hit ctrl alt delete to close out the install
tried many times same results stops at different stages of the install each time usually go's a little further each time, strange..   
and when i boot mach4 now i now get the error messages, and even though it did not complete the install mach4's info shows the new version #4322 running

its a external video card radeon  r9 380
I have never changed any of the settings..

Gary

Offline gorf23

*
  •  138 138
    • View Profile
Re: New mach4 ERROR's after install
« Reply #6 on: October 29, 2019, 01:54:56 PM »
just an update i installed the newest version of mach4 on a second computer with a different video card and i am getting the same ERROR's..

Gary

Offline smurph

*
  • *
  •  1,187 1,187
  • "That there... that's an RV."
    • View Profile
Re: New mach4 ERROR's after install
« Reply #7 on: October 30, 2019, 12:05:43 AM »
We are testing a new way to make thinker lines in the tool path.  This is what you get with development versions.  :( 

Steve

Offline thosj

*
  •  376 376
    • View Profile
Re: New mach4 ERROR's after install
« Reply #8 on: October 30, 2019, 10:24:49 AM »
For the ever brave, 4336 seems to have fixed this video error!!