Hello Guest it is January 28, 2020, 08:15:38 AM

Author Topic: Keyboard Jogging Not Working  (Read 293 times)

0 Members and 1 Guest are viewing this topic.

Keyboard Jogging Not Working
« on: October 20, 2019, 06:41:17 PM »
I have mapped the standard arrow keys and page up/down keys for jogging in the Mach4 plugin.
The keyboard shows being on but the mapped keys do not function at all.
Can someone point me in a direction to figure out why this does not work in Mach4?
Re: Keyboard Jogging Not Working
« Reply #1 on: October 20, 2019, 08:12:11 PM »
Hi,
have you enabled the keyboard plugin?
Have you enabled keyboard jogging?

Craig
My wife left with my best friend...
     and I miss him!
Re: Keyboard Jogging Not Working
« Reply #2 on: October 20, 2019, 10:06:58 PM »
Thanks for the response. You helped solve the mystery.
I had the plugin installed and on but did not fully finish defining the functions in the far right column of the plugin.
All good now, Thanks Again!
Re: Keyboard Jogging Not Working
« Reply #3 on: October 29, 2019, 08:54:46 AM »
One thing I have noticed is after programming the keyboard inputs they work fine.
For some reason after closing down Mach4 and restarting the software the keyboard mappings are gone.
Is this a know problem with Mach4 or something I'm not doing to say the keyboard mappings somewhere?

Offline thosj

*
  •  376 376
    • View Profile
Re: Keyboard Jogging Not Working
« Reply #4 on: October 31, 2019, 08:36:21 AM »
I had this problem, the keyboard mappings not saving, one time and it ended up being a VistaCNC pendant plugin conflicting somehow. I removed the plugin, did my keyboard mapping, quit Mach4, restarted, re-enabled the plugin, all was good. I haven't fuddled with this for a long time as I don't change keyboard mappings on a whim, but something to think about.
Re: Keyboard Jogging Not Working
« Reply #5 on: October 31, 2019, 09:22:22 AM »
I had this problem, the keyboard mappings not saving, one time and it ended up being a VistaCNC pendant plugin conflicting somehow. I removed the plugin, did my keyboard mapping, quit Mach4, restarted, re-enabled the plugin, all was good. I haven't fuddled with this for a long time as I don't change keyboard mappings on a whim, but something to think about.

I also use a Vista Pendant so I will do the same and unplug it.
Thanks for the response!

Offline thosj

*
  •  376 376
    • View Profile
Re: Keyboard Jogging Not Working
« Reply #6 on: October 31, 2019, 09:50:46 AM »
I'm not sure unplugging it will work, but give it a try. I actually removed the plugin in the Mach plugins folder, did the keyboard thing, saved, exited, put the plugin back, restarted. You might be sure you have the latest plugin from Lee at VistaCNC, but really not sure he ever fixed this. There is some kind of conflict with that plugin and the keyboard plugin somehow!!

Tom