Hello Guest it is November 14, 2019, 01:21:30 AM

Author Topic: Mach3 starts moving without turning the hand wheel  (Read 173 times)

0 Members and 1 Guest are viewing this topic.

Mach3 starts moving without turning the hand wheel
« on: October 09, 2019, 12:08:27 PM »
I have a CSMIO IO-S controller with Mach3 running, Firmware Version updated to V2.910

When I select an axis on my handwheel my machine starts moving on this axis. When I turn off the axis, everything works normal, that means I can now make intended movements on all axes pressing the desired arrow buttons on my mach3 screen. as soon as I select an axis with my hand wheel, mach3 starts moving alone again, and I cannot influence this movement with the jog wheel.
it happened with the prior firmware version, too, but now, after the update, it still happens. my hand wheel has an option to change the resolution, and if I change it, the speed of the unwanted movements change, too. also the emergency button on the hand wheel is working, so there is a kind communication between the csmio and the hand wheel. in the mach3 info-tab of the mpg expansion module status is "active", firmware version is 1.10 if I click on the table row of the mpg expansion module there opens a window with shows the voltage of the analog inputs of the CAN bus, and it is always on 0V on the scale between 0V and 5V.
I tried to deactivate and reactivate the hand wheel in the software, also unplug and replugging did't change anything, and of course I tried to restart everything a few times...

any recommendations?

thank you!