Hello Guest it is June 12, 2024, 09:58:49 PM

Author Topic: PC Locks up soon as CNC power is applied (LPT Port)  (Read 954 times)

0 Members and 1 Guest are viewing this topic.

PC Locks up soon as CNC power is applied (LPT Port)
« on: September 24, 2019, 11:43:13 AM »
Hey Guys,

Got a fun problem here. This isn't my first machine so I'm a bit stumped.

I'm trying to run an old xenetech engraver off of Mach3. Had an older PC with parallel port lying around so thats what I used

Control box consists of:
KL-4875 Torroid PSU. 48V
3x Gecko G251's, current limited to 2.2A
Cheap Amazon ST-V3 DB25 breakout board. ST-V3 is powered from the KL4875's 5v module on the side.

As the title suggests, when I power on the CNC control, the computer locks up. Not entirely though. I can move the mouse. But clicking anything does nothing. If i click any icon, any drop down menu..no response. Soon as I kill CNC power, it magically works again.

I was able to use the keyboard to jog the motors around and that worked fine.

I called it quits for the night when the 5A breaker tripped on the last powerup.

Ground issue? Everything is plugged into the same power strip. The one thing I question is the fact that i have my chassis gnd on the control box going to the AC incoming cord. This also doubles as a GND on the DC side as gecko drives ground themselves through the heatsink.

Thoughts? Ideas? Really don't want to blow anything up.

thanks in advance!
Re: PC Locks up soon as CNC power is applied (LPT Port)
« Reply #1 on: September 25, 2019, 01:44:23 PM »

Ive tried a known good PC, other cables, same result. Even lifted the earth ground from the chassis and no difference.

Would the idea of a voltage being backfed into the LPT port do it? Cause i have a CNC4PC board coming tomorrow. Im starting to suspect this ST-V3 board is junk.