Hello Guest it is April 14, 2021, 11:19:04 PM

Author Topic: Help! G41 doesn't work for multiple offsets!  (Read 545 times)

0 Members and 1 Guest are viewing this topic.

Help! G41 doesn't work for multiple offsets!
« on: September 05, 2019, 02:28:38 PM »
Hi.
I have many parts which have 2 operations. I have 2 fixtures mounted to my table. Im using G54 for one fixture, and G56 for the other in the same program. Mach3 will machine everything perfectly, until it gets to the precision bore sizes and I use G41 cutter compensation. Then it will go nuts.
If I have G54 as active offset when I load the program, it will generate perfect toolpath for G54, and crazy scribble for the G56 portion using G41. If I select G56 as active work offset when I load the program it will generate crazy scribble for the G54 portion using G41. If G55 or any other is active work offset both toolpaths have crazy scribble for the G41 portion. I'm certain Mach is using the currently selected active work offset for toolpath generation, instead of programmed work offset.

I also tried using only G54, and writing in my other fixture with G52 offset. This gives me the same errors. The code is perfect until G41 is involved.

Is there a fix for this?

Thanks.
Re: Help! G41 doesn't work for multiple offsets!
« Reply #1 on: September 05, 2019, 03:06:01 PM »
Does Mach4 correct this?

Offline Graham Waterworth

*
  • *
  •  2,305 2,305
  • Yorkshire Dales, England
    • View Profile
Re: Help! G41 doesn't work for multiple offsets!
« Reply #2 on: September 08, 2019, 07:46:14 PM »
Cancel the offset with G40 then change work offset then call G41 again.

E.g.

G21 G40 G00 G99
T0101
G54 G00 G43 X0 Y0 Z25.
Z-5.
G01 G41 D1 X12. F25.
G03 I-12.
G01 G40 X0
G00 Z25.
G56 X0 Y0
Z-5.
G01 G41 X12. F25.
G03 I-12.
G01 G40 X0
G00 Z25.
M30
Without engineers the world stops
Re: Help! G41 doesn't work for multiple offsets!
« Reply #3 on: September 11, 2019, 12:26:20 PM »
Cancel the offset with G40 then change work offset then call G41 again.

E.g.

G21 G40 G00 G99
T0101
G54 G00 G43 X0 Y0 Z25.
Z-5.
G01 G41 D1 X12. F25.
G03 I-12.
G01 G40 X0
G00 Z25.
G56 X0 Y0
Z-5.
G01 G41 X12. F25.
G03 I-12.
G01 G40 X0
G00 Z25.
M30


Doesn't work in Mach3.
Mach3 bases the toolpath off of selected active work offset.

Load a tool diameter and separate offsets and run it in Mach3 and you see what I mean. Other machines ive ran besides Mach3 would do this fine all day long.

Offline Graham Waterworth

*
  • *
  •  2,305 2,305
  • Yorkshire Dales, England
    • View Profile
Re: Help! G41 doesn't work for multiple offsets!
« Reply #4 on: September 12, 2019, 08:58:47 PM »
I know I am running Mach3 and it works here just fine as per the example given.

If you are talking about the tool path on screen then yes the screen gets screwed up but not the machine tool path.

Without engineers the world stops
Re: Help! G41 doesn't work for multiple offsets!
« Reply #5 on: September 12, 2019, 09:03:52 PM »
Mine runs with the toolpath. Upon further searching, i found that so did everyone else's.