Hello Guest it is December 06, 2019, 03:44:51 AM

Author Topic: Mach Four Crashes at Digitize (probe) signal  (Read 176 times)

0 Members and 1 Guest are viewing this topic.

Mach Four Crashes at Digitize (probe) signal
« on: August 30, 2019, 10:54:16 PM »
I have a hicon ingera (the newer black one).
Windows 7 Professional 64 bit
Intel I7
2.8 ghz
The "probe" input is wired to #8 shown in the picture J13 inputs. I unplugged the Relay input for the torch to take a clearer picture.

The probe signal alone seems to work fine. If I activate it, both Mach 4 and the controller board light up.

I tested it repeatedly with nothing but "M03" as the G code.

The torch moves down and as soon as the probe is active, the torch stops moving and mach 4 crashes.
It happens every time.

There is nothing in the history readout at the bottom, and no error messages from windows.

I tried restarting Mach 4, restarting the computer, and using a different input on the Hicon.

Interesting side note. even if I turn the THC off it still tries to probe. I crashed my torch into the table 3 times because of this. After that I stopped trying. Of course I would like to use THC, but I can't even turn it off temporarily to manual set the height. I had to exit and setup another profile to get around the THC function.
« Last Edit: August 30, 2019, 10:57:11 PM by jengineer1 »
Re: Mach Four Crashes at Digitize (probe) signal
« Reply #1 on: September 04, 2019, 10:40:41 AM »
Hello Jeremy,

Mach4+HiCON plugin is not supported on windows 7 as some of the new windows API is not available on windows 7.  We request the users to upgrade to windows 10 to solve the compatibility issues and to benefit from the upcoming improvements and features from the HiCON plugin-firmware development.

-Support Team,
Vital System Inc.,