Hello Guest it is January 20, 2022, 12:14:53 AM

Author Topic: is there a way to disable automatic zoom of screen elements?  (Read 530 times)

0 Members and 1 Guest are viewing this topic.

Hi,

recently I worked on new mach4 Screensets. I want to use a monitor in portrait mode, as it wastes less space ...

I created the screen set in a win7-VM on my linux desktop. In edit mode mach4 works fine in VM. Outside edit mode toolpath area stays on top of all, even if you switch notebook to a page without toolpath ...
Picture Mach4_VM_01.png shows the actual result (which looks quite nice to me).
As I could not manage font handling of static texts, I used bitmaps instead of static texts.

Then I took the screen file to a box running native win7, where my screen set looks really weird.
Main menubar is displayed twice (now parts of titlebar are shown twice) and many sizes/positions and font-sizes don't match.
Picture Mach4-OWin_01.jpg shows a screenshot.

Then I switched to mach4 into fullscreen mode (Mach4-OWin_02.jpg). Now the whole screen is wrong sized.

My intention for this screen set was, to create a screen, that can be managed without mouse - and for those I tried to avoid child windows, popups and the like.
I was able to reimplement tooltable and fixtures list as notebook page, but I did not find a way to do inplace editing of loaded gcode file (yet).

I would be very happy, if someone can guide me to a way to inhibit automatic zooming or even automatic font size changes.

Cheers Reinhard

P.S. both win7 installations are the same and mach4 is build 4199

Offline smurph

*
  • *
  •  1,475 1,475
  • "That there... that's an RV."
    • View Profile
Re: is there a way to disable automatic zoom of screen elements?
« Reply #1 on: May 30, 2019, 10:21:51 PM »
The way to disable the automatic scaling of the screen elements is to develop the screen in the resolution that it will used.  E.g. 1200x1920 instead of 1024x768.  You will most likely need to start with the blank screen set, and then set the resolution before adding any elements. 

Mach 4 Industrial has tool table, offset, and in screen editor controls. 

Steve
Re: is there a way to disable automatic zoom of screen elements?
« Reply #2 on: June 04, 2019, 11:41:44 PM »
Hi Steve,

thank you for your attention and reply.
Sorry for the late response. I missed your posting, although notification was checked.

Anyway ...

Quote
The way to disable the automatic scaling of the screen elements is to develop the screen in the resolution that it will used.
Well, that was my assumption, but is not the reality.
I have a monitor with 1920x1200 rotated into portrait-mode.
So I built the screen (from scratch) with resolution 1200x1920

The "static text" will always perform an autoscale. Although not changed in size, the fontsize differs between edit- and work-mode and the scaled font will not be aligned to the font's baseline, so the letters get cropped (therefor I tried to use bitmaps instead of static texts)

The rotated screen orientation works fine in a virtualbox, but does not work on native windows box (this time it was win7). Rotation of screen is not performed by windows itself, but by the grafic driver (nvidia).

To me it looks like mach4 gets the screen-parameter from windows before rotation.
May be, it is necessary to ask a different layer?
Just guessing - I don't have any knowledge on that item.

Quote
Mach 4 Industrial has tool table, offset, and in screen editor controls. 
I built tooltable- and offset-table control with little lua coding. Result is ok for me.
OK, may be I have to build my own gcode-control as well.

Cheers Reinhard