Hello Guest it is October 18, 2019, 07:47:37 AM

Author Topic: Motors lock up but will not move when DROs move...Help!  (Read 215 times)

0 Members and 1 Guest are viewing this topic.

Motors lock up but will not move when DROs move...Help!
« on: May 07, 2019, 07:20:13 PM »
The machine has worked for years.
Power supply failed so I had my friend (owner of the machine a few years now) replace the power supply and it worked fine then he got his own license and when he installed the latest software using his license the motors will lock up but will not move.
He has been in contact with mach support and has spent many hours with them as well as me (I am 250 miles from him) and we still can't get the motors to move.
The limit switches respond in the diag page so at least part of the system is working.

Here is a look at what was used when the machine was built: http://www.seabreezeparachutes.com/7x13cncproject/casebuild/view.html

The power supply was changed and the machine did run after the change and it still locks up now when the power is turned ON. But there is no motor movement when the DROs move.

Running win XP
32 bit
printer port
Followed and repeated basic setup many times from many videos.
But again no movement from the motors but they do lock up when power is turned on.

Any idea what we are missing?

Thanks in advance!

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Motors lock up but will not move when DROs move...Help!
« Reply #1 on: May 07, 2019, 08:54:58 PM »
Check the port and pin assignments of the step and direction signals.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Motors lock up but will not move when DROs move...Help!
« Reply #2 on: May 07, 2019, 09:13:43 PM »
Check the port and pin assignments of the step and direction signals.

He set the A slave to X,  set hot keys,  set the X++, the X-- Y++ and Y-- Z++ and Z--. Set the output pins and the printer port is correct,
And still no movement.
There has to be something we are missing but the motors do lock up so that is a good sign.

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: Motors lock up but will not move when DROs move...Help!
« Reply #3 on: May 08, 2019, 02:24:31 AM »
here:
https://www.youtube.com/watch?v=uglCm_qsojk

is a Video how to test the single signals.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline reuelt

*
  •  444 444
    • View Profile
Re: Motors lock up but will not move when DROs move...Help!
« Reply #4 on: May 08, 2019, 03:33:47 AM »

i am guessing that when your friend installed the new version of MACH3, the working profile was replaced by the MACH3 default unconfigured XML file.
Try to restore your a backup mach3mill.xlm (or whatever profile) you had.
"the gift of God is eternal life through Jesus Christ our Lord"

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: Motors lock up but will not move when DROs move...Help!
« Reply #5 on: May 08, 2019, 04:01:03 AM »
Config -> ports & Pins -> Port Setup and axis selection

port#1 enabled ?
port address set correctly ?
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Motors lock up but will not move when DROs move...Help!
« Reply #6 on: May 08, 2019, 01:14:29 PM »
here:
https://www.youtube.com/watch?v=uglCm_qsojk

is a Video how to test the single signals.

Seams he is failing the voltage test and he says he is getting no voltage.
It could be the printer port has failed I guess.
I will have him check for the address of the printer port to be sure it is 0x378.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Motors lock up but will not move when DROs move...Help!
« Reply #7 on: May 08, 2019, 01:33:06 PM »
But he also said that the limit switches are working???
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: Motors lock up but will not move when DROs move...Help!
« Reply #8 on: May 08, 2019, 01:44:45 PM »
maybe you can post the Profile XML, then we can have a look.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.