Hello Guest it is June 20, 2019, 04:18:48 AM

Author Topic: DXF Import Not to Scale  (Read 3919 times)

0 Members and 1 Guest are viewing this topic.

Offline Bobo

*
  •  41 41
    • View Profile
    • Haus Metalworks
DXF Import Not to Scale
« on: March 31, 2006, 10:18:24 AM »
I just finished getting the X and Y axis running on my homebuilt Plasma table. I installed a pencil for a spindle for testing. I had the Cycle Jog set to 1.0000 and Jog Mode to Step and checked the motor tuning by jogging one full step and measuring the distance which was 1 inch, measured with a digital caliper within thousands. I then exported a 4 inch diameter circle from Unigraphics in DXF and imported it into Mach 2. It drew a very nice circle but it was about 1.5 inches in diameter.

The load DXF window in Mach 2 shows the max and min X and Ys to be exactly 4 inches but when I generate the gcode and look in the tool path screen in Mach2 is shows it to be about 1.5. It was mentions in another forum that it looks like inches in converted to centimeters.

Am I doing anything wrong?
Re: DXF Import Not to Scale
« Reply #1 on: March 31, 2006, 12:46:46 PM »
IF you use Lazy cam I can help you with anyproblem :)
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline ger21

*
  • *
  •  6,261 6,261
    • View Profile
    • The CNC Woodworker
Re: DXF Import Not to Scale
« Reply #2 on: March 31, 2006, 07:35:51 PM »
Post the code if you could. The .dxf inmport screen looks like 4"?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Bobo

*
  •  41 41
    • View Profile
    • Haus Metalworks
Re: DXF Import Not to Scale
« Reply #3 on: April 01, 2006, 04:13:16 PM »
Yes the DXF import window shows the circle to be 4 inches but you can see in the ToolPath window of Mach2 the Y axis range is only 1.5. Here's the gcode.
(File test5.tap )
(Thursday, March 30, 2006)
G90G80G49
G0 X-2.7659 Y-0.0969
M3
F20.000 G2 X-2.7659 Y-0.0969 I-0.7659 j-0.0969
M5
G0 X0 Y0
M5M30

Offline ger21

*
  • *
  •  6,261 6,261
    • View Profile
    • The CNC Woodworker
Re: DXF Import Not to Scale
« Reply #4 on: April 03, 2006, 09:46:51 AM »
Try changing your I,J settings under Config>State. You probably have them set at incremental, and I think the .dxf importer uses absolute.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Bobo

*
  •  41 41
    • View Profile
    • Haus Metalworks
Re: DXF Import Not to Scale
« Reply #5 on: April 03, 2006, 11:58:07 AM »
IJ mode absolute fixed it.

Thx Gerry

Offline Bobo

*
  •  41 41
    • View Profile
    • Haus Metalworks
Re: DXF Import Not to Scale
« Reply #6 on: April 03, 2006, 12:12:56 PM »
Strange,,,,, while set to incremental, importing a square was to scale but a circle was not.

Offline ger21

*
  • *
  •  6,261 6,261
    • View Profile
    • The CNC Woodworker
Re: DXF Import Not to Scale
« Reply #7 on: April 03, 2006, 01:53:33 PM »
That only affects arcs (G2 and G3), not straight lines (G1)
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html