Hello Guest it is May 15, 2021, 12:59:59 AM

Author Topic: Y-axis motor not running in sync  (Read 578 times)

0 Members and 1 Guest are viewing this topic.

Offline cruz

*
  •  19 19
    • View Profile
Y-axis motor not running in sync
« on: February 02, 2019, 03:35:57 PM »
hi everyone,

a few days ago i added planetary gear reductions to my Y-axis (the axis has 2 motors, one on each side).
it's a 5/1 ratio and the machine runs smoother with it, and if a can get it to work correctly i'll do the X-axis as well.

after i put the gear reduction in, i calibrated the axis again in the settings page in mach3.
when i jog the y-axis with the steps per value mach3 gave, the whole bridge of the table twists, like 1 motor is running faster than the other one.
if i lower the steps per value (from 153 to 100) the problem goes away and the machine runs smooth and straight.
the y-axis before the gear reduction had drivers that were set to 25000 pulses/rev.
when i placed the reductions i changed those to 1600 pulses/rev.
also mach3 kernel speed is set to 100KHZ.

this seem a problem in the settings for the drivers and mach3 right?
no mechanical problem i would think?

anyone any idea what the issue could be?
Re: Y-axis motor not running in sync
« Reply #1 on: February 02, 2019, 03:57:56 PM »
Hi,
the Mach3 kernel speed refers to the interrupt driven timer that Mach uses as its source of timing 'ticks' to generate
the motor pulse streams. Mach3 has a native kernel seed of 25 kHz.

You will have observed the 'jitter' which is reported by the DriverTest.exe program. Commonly the jitter or timing variance
will be 4 us. Remember that at 25kHz the period is 40 us. So the jitter is about 10% of the period.

You can as you have done increased the kernel speed but now the jitter (4 us) is about 40% or the period (10us)!
Quite frankly I'm surprised that you can get the parallel port to run at all! I would put it back to 25kHz. Note that you need
to restart Mach if you change the kernel speed. Once you have worked out the new (accurate) 'steps per unit' then you might
find it necessary to increase the kernel speed, but I've never heard of anyone getting good results at 100kHz.

The recommendation is that "Run Machs kernel speed at the lowest possible rate for the most stable results".

I think you have your settings all screwed up. If you had a 'steps per unit' value of nnn prior to the fitment
of the gearboxes then the new 'steps per unit' value should be 5 X nnn. It suggests to me that you have changed the
microstepping of your drivers as well.

What is the pitch of the ballscrews?
Are they direct coupled to the output of the gearbox?
Is the stepper direct coupled to the input of the gearbox?
What microstepping regime have you set your drivers to?

Craig
My wife left with my best friend...
     and I miss him!

Offline cruz

*
  •  19 19
    • View Profile
Re: Y-axis motor not running in sync
« Reply #2 on: February 02, 2019, 04:07:51 PM »
okay i'll change the kernel speed to lower setting.
yes, i did change the microstepping (pulse/rev)
microstepping is now set to 1600 pulse/rev.
it was set at 25000 before the gear reduction, but i was advised to lower it because with the gear reduction you don't need such a high microstepping.
the motor goes directly in the reduction, and the outgoing shaft of the reduction has a gearhead.
that gearhead goes directly in a rack and pinion.
i don't know the number of teeth.
Re: Y-axis motor not running in sync
« Reply #3 on: February 02, 2019, 04:42:37 PM »
Hi,
Ok. Microstepping does not really improve the resoltuion of a stepper, as much as we might like to think it does.
The real value of microstepping is smooth motion.

A stepper at full step mode is highly inclined to vibrate, a so called mid-band resonance. A stepper in half step
mode is better and better again in 1/4 step mode. At about 1/8 step mode though you have gotten about as much
advantage as you are going to get and so microstepping in 1/16, 1/32, 1/64 step modes is just not worth it. You have
to signal the steppers that much faster to maintain axis velocity that you WILL have to increase the kernel speed
to the point of unreliability.

Given that you have fitted a gearbox that will make your stepper very much LESS subject to mid-band resonance
and you could robably recuce microstepping to 1/8 but 1/4 or 1/2 or maybe even fullstep would be OK.
May I suggest your existing 1600 pulse per rev (1/8 th micosteping) is adequate.

1600 pulses will rotate the stepper one turn but the gearbox requires five turns at the input to achieve one turn at
the output, so 5 x 1600 = 8000 pulses per revolution of the gearbox output shaft.

If you rotate the pinion one turn, how far does the axis travel?

If I guessed 75mm then the 'steps per unit' for that axis (with 1/8th microsteping and 5:1 gearbox) would be
8000 /75 =106.66 pulses per mm.

If you can accurately measure the distance the axis moves for exactly one rotation of the pinion you can calculate
the required 'steps per unit' value. If you can't measure it accurately then you will have to use the axis calibration feature
of Mach which is 'make a guess' try it and measure how far the axis went and adjust your guess to suit. Keep repeating
until its accurate. Thus making your initial guess as good as you can will help.

Craig
My wife left with my best friend...
     and I miss him!

Offline cruz

*
  •  19 19
    • View Profile
Re: Y-axis motor not running in sync
« Reply #4 on: February 02, 2019, 06:15:52 PM »
Hi,
Ok. Microstepping does not really improve the resoltuion of a stepper, as much as we might like to think it does.
The real value of microstepping is smooth motion.

A stepper at full step mode is highly inclined to vibrate, a so called mid-band resonance. A stepper in half step
mode is better and better again in 1/4 step mode. At about 1/8 step mode though you have gotten about as much
advantage as you are going to get and so microstepping in 1/16, 1/32, 1/64 step modes is just not worth it. You have
to signal the steppers that much faster to maintain axis velocity that you WILL have to increase the kernel speed
to the point of unreliability.

Given that you have fitted a gearbox that will make your stepper very much LESS subject to mid-band resonance
and you could robably recuce microstepping to 1/8 but 1/4 or 1/2 or maybe even fullstep would be OK.
May I suggest your existing 1600 pulse per rev (1/8 th micosteping) is adequate.

1600 pulses will rotate the stepper one turn but the gearbox requires five turns at the input to achieve one turn at
the output, so 5 x 1600 = 8000 pulses per revolution of the gearbox output shaft.

If you rotate the pinion one turn, how far does the axis travel?

If I guessed 75mm then the 'steps per unit' for that axis (with 1/8th microsteping and 5:1 gearbox) would be
8000 /75 =106.66 pulses per mm.

If you can accurately measure the distance the axis moves for exactly one rotation of the pinion you can calculate
the required 'steps per unit' value. If you can't measure it accurately then you will have to use the axis calibration feature
of Mach which is 'make a guess' try it and measure how far the axis went and adjust your guess to suit. Keep repeating
until its accurate. Thus making your initial guess as good as you can will help.

Craig

hi Craig,

so 1600 pulse/rev is good, i could go lower to 400 pulses/rev

i don't really have a accurate way of measuring how much it moves with one rotation.
i'll just use the calibrate method mach3.

but if i use the mach3 calibrate method it gives me the steps per value.
this is how i do it:
- start the calibrate process in the settings page
- choose the axis Y-axis in this case
- tell it how far to move (i've then already checked where the torch is in relation to the edge of the table)
- measure how far it actually moved and give that measured value back to mach
- mach then gives me a updated steps per value and asks me if i want to use that value.

is this correct?
Re: Y-axis motor not running in sync
« Reply #5 on: February 02, 2019, 06:26:42 PM »
Hi,

Quote
- start the calibrate process in the settings page
- choose the axis Y-axis in this case
- tell it how far to move (i've then already checked where the torch is in relation to the edge of the table)
- measure how far it actually moved and give that measured value back to mach
- mach then gives me a updated steps per value and asks me if i want to use that value.

is this correct?

Yes, that is the process. You will have to make a guess as to the correct starting point. You need to measure it as best
as possible. If you are going to rely solely on the Mach routine to calibrate the axis for you are going to have trouble.

Craig
My wife left with my best friend...
     and I miss him!

Offline cruz

*
  •  19 19
    • View Profile
Re: Y-axis motor not running in sync
« Reply #6 on: February 02, 2019, 06:28:51 PM »
Hi,

Quote
- start the calibrate process in the settings page
- choose the axis Y-axis in this case
- tell it how far to move (i've then already checked where the torch is in relation to the edge of the table)
- measure how far it actually moved and give that measured value back to mach
- mach then gives me a updated steps per value and asks me if i want to use that value.

is this correct?

Yes, that is the process. You will have to make a guess as to the correct starting point. You need to measure it as best
as possible. If you are going to rely solely on the Mach routine to calibrate the axis for you are going to have trouble.

Craig

ok, i'll work on it tomorrow.
i'll let you know how it went.

thanks already