Hello Guest it is November 20, 2019, 06:26:27 AM

Author Topic: G81 Problem with rotary stopping exact  (Read 398 times)

0 Members and 1 Guest are viewing this topic.

G81 Problem with rotary stopping exact
« on: February 06, 2019, 03:33:23 PM »
Hi, I'm new to Mach3, but I've done GCode before.  I'm having trouble with using G81 to drill many holes on my rotary axis.  It drills the first hole correct, but while moving to the next hole position, it travels too far.  This happens offline too.  The example below drills a hole at A356, then goes to A358.14 and increases from there.  X axis starts to very slowly move as well.  Strange!

G0 X0.3
G0 A356
G81 R0.25 X-0.5
A358
A0
A4
G80
G0 A0

If I replace the G81 with G0 A358 G1 X-0.5, it will stop exactly on 358.
What am I doing wrong?
Re: G81 Problem with rotary stopping exact
« Reply #1 on: February 07, 2019, 09:19:38 AM »
It seems to have something to do with the "Rot 360 rollover" and "Ang Short Rot on G0" options in general config (under Rotational).  When I enable any of these, the rotation axis doesn't stop exactly on the commanded spot, but only after the G81 command.  Anyone experience this?  I've tried reducing the accel and speed of the 4th axis, but nothing seems to fix it.
Re: G81 Problem with rotary stopping exact
« Reply #2 on: February 07, 2019, 09:49:00 AM »
It works if I use a sub routine and end the cycle.  That's my work around for now.

G0 X0.3
G0 A356
M98 P1000
A358
M98 P1000
A0
M98 P1000
A4
M98 P1000
G0 A0
M30

O1000
G81 R0.25 X-0.5
G80
M99