Hello Guest it is October 18, 2019, 10:44:58 PM

Author Topic: Jog buttons are not activated  (Read 298 times)

0 Members and 1 Guest are viewing this topic.

Jog buttons are not activated
« on: January 23, 2019, 03:52:06 PM »
Hi

I have a weird behaviour on my Mach 4.
When I start Mach 4 and "Activate" and the try to Jog, then the jog buttons are not active.
I have to go into "Edit Screen" and then exit "Edit Screen" again. The they are active.
So I don't edit anything, but just go into "Edit Screen".
This is quite annoying. 
I have tried to insure the button are active as a standard setup for the Jog buttons.

Any ideas?
Re: Jog buttons are not activated
« Reply #1 on: January 24, 2019, 01:01:48 AM »
Hi,
I assume you mean that when you first start Mach the arrow buttons on the keyboard don't work?

That is normal, its not so much that jogging doesn't work but that the keyboard arrow buttons are by default disabled
on start up.

If you go to the jogging tab and click the <Keyboard Inputs Enable> button and try again.

Craig
My wife left with my best friend...
     and I miss him!
Re: Jog buttons are not activated
« Reply #2 on: January 24, 2019, 01:05:24 AM »
Hi,
just a quick question, do you have the Keyboard Inputs plugin enabled?

Craig
My wife left with my best friend...
     and I miss him!
Re: Jog buttons are not activated
« Reply #3 on: January 24, 2019, 01:34:27 AM »
Hi,

I will try your suggestion out tonight  :)
I have never used the keyboard for jogging. I always use the buttons on the screen and the mouse.
That is also the ones I’m referring to. It’s something that has happens since I upgraded and reinstalled Mach 4 (and maybe I have touched something  ;) )
I Will check if the keyboard input plugin is enabled, I can’t recall.

Brian
Re: Jog buttons are not activated
« Reply #4 on: January 24, 2019, 08:21:24 AM »
It sounds like something that happened to me a while back.  You press one of the jog buttons and it locks up some other buttons?
Mine was because I didn't have a motion device selected; kind of weird because the SIM should allow jogging on screen jogging, but, that's what it was. 
Another time it was because somehow my motors were turned off and it locked stuff up; this has been over a year now, but that's what happened to me before. 
Chad Byrd
Re: Jog buttons are not activated
« Reply #5 on: January 24, 2019, 11:32:05 AM »
Solved!

Hi again,
Of course it was me who did something.
It was the whole tab that wasn't enabled. After I checked this it works. See picture.

Thanks for the suggestions  :)

Brian