Author Topic: SmoothStepper Motor Steps Per Unit  (Read 206 times)

0 Members and 1 Guest are viewing this topic.

Offline Cbyrdtopper

  • Active Member
  • Posts: 615
    • View Profile
    • Byrd Tool Corp.
Re: SmoothStepper Motor Steps Per Unit
« Reply #10 on: January 15, 2019, 11:41:20 AM »
The status message, "Axis 3 commanded while disabled" is because in the "Go To Work Zero" button, A axis is commanded to go to 0.00 as well as X, Y, and Z. 
There are a couple of ways you can fix this.
1.  Go into the screen editor and edit the goto work zero function in the screen load script to not include the A axis move.
2.  Simply enable motor 3 in mach config.  If you don't have using motor 3 this won't have any adverse effects, it will just be enabled.

I am using the ESS on a mill with Mach4 and I do get a little bit of funny noise while jogging, it messes with my spindle slightly and extremely briefly.  I haven't messed with the ESS Config in a while, but is there a way to reduce noise on it?  Maybe it is getting a false keyboard press? 
Chad Byrd